Having trouble with Zoom screen sharing on Wayland in Fedora 40

Hi!
I’m unable to share my screen in the Zoom client while using Fedora 40 with KDE and Wayland. However, screen sharing works fine with Fedora 40 and KDE using X11. I’ve tried using the Zoom RPM, Flatpak, and Snap packages, as well as the Pipewire option for screen sharing, including DBuss session option, org.gnome.* option, but none have resolved the issue. While I can use the web version of Zoom with Wayland, it lacks options as the desktop client.

Operating System: Fedora Linux 40
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.8.8-300.fc40.x86_64 (64-bit)
Graphics Platform: Wayland
Zoom client: 6.0.2

Can anyone help me troubleshoot this issue with Zoom on Wayland?
Thank you!

Removed gnome

Had the same issue and the following worked

settings->share screen->advanced


select pipewire mode

start call and select share screen. then select desktop or window then share

select screen then share - badabing

2 Likes