Can you share your desktop on Zoom? (isn't working for me)

Sadly I haven’t been able to show off Gnome40 to my non linux-friends.

Functionally, I can share my screen on zoom and they can see whatever application I’m using.

However, they can’t see the desktop ui elements themselves. The desktop, the top bar, the task switcher, the app search etc

I suspect it’s because Zoom is in a flatpak, I have tried playing with the settings in Flatseal but to no avail.

Anyone found success here?

My laptop has nvidia, so I default to xorg session.

I use the zoom flatpak under xorg without any issues. I can share windows or applications, and don’t have any issues with zoom.

From time to time I switch to wayland, but I’ve had very poor experiences with zoom flatpak under wayland. While I am typically able to share my monitor (but not apps), in my experience the app hangs and crashes frequent enough to be a non-starter for me.

1 Like

Mine’s a System76, I’m assuming with Intel chips. I’m using Wayland. Fedora 34 silverblue.

It’s such a minor problem. I can share apps only, the desktop UI elements I’m told are “stripy”.

I’d verify if the experience is the same or worse on xorg.

Looks like there are already a few wayland bugs reported, but if u don’t see your exact issue you can report a new issue:

1 Like

It’s because of electron, lack of support, testing and probably subpar development practices.

Sorry to be like this… A workaround that works for me is to use Zoom in a real browser: I tried in Firefox in Flatpak and it works™. I mean it: I can share my screen or an app just perfectly, without crashes nor stripes. The only downside is you don’t get the video grid like in the electron version. There is no reason that should happen, except if that’s a deliberate choice (hence the comment above). You might have to fake your user agent (mine is all the time to say I’m using Windows) but I’m pretty sure that’s not necessary. Perfect for 1-to-1s but not so perfect in groups.

I was just talking about this with someone on the desktop team @ RH. The problem is that Zoom uses a non-standard internal API instead of the one that they’re supposed to for screen sharing. The good news is that the developers are talking and I hope this will get worked out.


Amazing that there is some discussion going on! I, too, hope this is going to be fixed.

This is really good to hear!