Fedora's (registry.fedoraproject.org) LibreOffice flatpak crashing after latest update

This happened after the latest LibreOffice flatpak update. So sometime yesterday for me.

I haven’t seen anyone post about this yet, not even on Reddit or GitHub (last I checked), so I’m starting to wonder if anyone else even uses the flatpak from registry.fedoraproject.org? I use it since it’s what pops up for me by default in GNOME Software (and I tend to opt for Fedora-sourced flatpaks with all other apps as well).

I run Silverblue on seven different machines. A variety of Lenovo, Dell, and HP laptops, two Lenovo m93p Thincentres, and one custom built gaming desktop. No NVIDIA anywhere, all Wayland. Only layered packages are steam-devices and simple-scan.

● fedora:fedora/36/x86_64/silverblue
                  Version: 36.20220728.0 (2022-07-28T00:44:48Z)
               BaseCommit: 71c9f4b42bf3d6d7e1206bc2ff2e778821a4fec768452963f3a070668dcacb2b
             GPGSignature: Valid signature by 53DED2CB922D8B8D9E63FD18999F7CBF38AB71F4
          LayeredPackages: simple-scan steam-devices

Some LibreOffice apps open and crash after trying to do something in the menu. Namely, LibreOffice Calc.

Some crash on open, like LibreOffice Writer.

I ran the application in safe mode, reset to factory settings. No effect.

I deleted the .var config folder for LibreOffice. No effect.

I reinstalled the flatpak itself. No effect.

Installed the flathub version of LibreOffice and noticed no issues whatsoever.

Here’s my terminal output from trying to open Fedora’s flatpak of LibreOffice Writer:

javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc
terminate called recursively

Fatal exception: Signal 6

On the GUI side of things, when I try to open LibreOffice Writer using the menu icon, I get this:


Besides uninstalling this and using the flatpak from flathub, any help would be appreciated! Thank you!

1 Like

Hello @benkei-kuruma ,
Welcome to ask.:fedora:project.org!
Yes I can confirm there appears to be an uncaught exception in the LibreOffice flatpak. Though I do not have any java runtime errors.


Hrm, if this is the Flatpak from the Fedora registry, I expect one should file a bug to inform the maintainers. You can use the “file a bug report” link here to file one:


Thank you both! I’ll report the bug.

And just for the record, I’m migrating all of my flatpaks to flathub. Easier to manage them that way.

If anyone is Googling and wants a simple way to migrate from fedora remote to flathub, here’s what I did:

flatpak install $(flatpak list --app --columns=application) --reinstall

When asked, choose “flathub” remote, or otherwise choose “yes” for a flathub flatpak it wants you to install as a dependency.

After it’s done, remove the fedora remote from your system with:

flatpak remote-delete fedora

When prompted, remove the fedora platform runtimes, which should be the only thing remaining on your system from the fedora remote.

Just for good measure, run this last:

flatpak remove --unused

you can also specify the remote in the install command with flatpak install [OPTION…] [LOCATION/REMOTE] [REF…] so in the case of flathub flatpak install flathub [application ref]

This bug still seems to exist in Fedora’s flatpak.

Indeed, I see some movement at my bug report, but I’ve since removed the Fedora remote and use flathub exclusively, as noted above. This is honestly quite a long time for a showstopping bug to persist in such a standard use case piece of software like a word processor, something many rely on for school or work. Then again, I wager no one really uses the Fedora remote version anyway.

Well in response to …

It works fine from the Fedora official repo when installed via DNF.

Why not? Fedora flatpaks receive the same review process and QA as any package in the official Fedora repo, so they are better than the flathub (I don’t know for sure where this came from) version in that respect.

1 Like

Flatpaks from any source are inherently not kept as up to date as the rpm versions. This is due to delays in receiving the latest software, building the flatpak, testing, distribution, etc.

The nature of flatpaks are that they should work for the version they were tested on and all later versions, but changes in the underlying OS (including the kernel) may interfere.

If at all possible users should use the rpm versions and only use flatpaks for the outlier reasons (such as on silverblue, kinoite, or other systems that are immutable, or other cases where the rpm is not available).

Yeah word, I mean theoretically, there shouldn’t be a difference between rpm and fedora remote flatpaks, right? Maybe the rpm is broken as well. Or not, since I haven’t seen anyone post about it either.

That no one else has posted about this crashing bug anywhere else on the web (to my knowledge) kinda implies no one else is using the Fedora remote for this flatpak, or there is something wrong with Silverblue. I wouldn’t know either way. I have seen others post about other issues with Fedora remote flatpaks, though.

I half expected to see this under “common issues” but didn’t. So I made this account to post about the bug after troubleshooting, searching, and waiting a few days for a patch. :sweat_smile:

Or it could be that Fedora flatpak users just don’t use libre office? :thinking: Again, I wouldn’t know. I’m just some dude. :wink:

Definitely not, as I stated it works fine as installed on Fedora Workstation from the official Fedora Linux repo.

Or it could mean only a few are getting hit with it. I don’t see the correlation to “something is wrong with Silverblue” though.

1 Like

Yeah, I dunno man. :man_shrugging:t5: Silverblue is really the only constant among all the computers I have tried this flatpak on. Just common sense deduction here, where if it ain’t the flatpak remote itself, it must be the immutable OS.

I’m rather tired of this pointless back-and-forth at this point, though. All I’m saying is, I’m willing to be a lot more people are using the flathub version (i.e., not just Fedora users), hence more eyeballs, bug reports, and attention. If the flathub version of libre office was broken for a whole week, I’m willing to bet someone would have said something by now. But I could be wrong. I don’t really follow these things as much as you might.

Not really sure what else there is to say, but it probably doesn’t matter in the grand scheme of things since apparently no one else is affected.

I got it working with flathub so I’m good. Hope the bug gets fixed for others regardless.