Legacy install on gpt layout; anaconda asks for biosboot

Is that your bug report? Are you trying to stripe volumes and put your /boot/efi on them? That is the scenario in which I have seen the use for the 1mb biosboot. Also, are you using advanced partitioning blivet-gui

I looked at that bug report and have 2 suggestions.

  1. Do not stripe the disk partition needed for efi (raid 0). Doing so means the kernel would already need loaded before reading the device but booting is not possible since grub cannot read a raid drive. (An exception to this would be if the raid was on a hardware controller so the OS did not manage it)
  2. Same for /boot. Again, grub must be able to read the /boot partition and it cannot read a raid device. Raid devices managed by software raid (mdadm) are not available until the kernel has already been loaded.

In general raid 0 is not really reliable since a single device failure takes out the entire raid array, and there is at least one point of failure possible for each device used for striping. Raid 1 is better in that there are 2 devices for each mirrored pair and one failure does not destroy the entire file system.

oh, sorry, my link to my bug report was probably ill-placed here. I apologise.
No, I did not attempt to generate /boot / /boot/efi as raid. Indeed, Anaconda was telling me about the biosbootpartitions independently of any specific configuration of the new partitions. I did not yet attempt using blivet-gui.

biosboot is created when a disk with gpt partition scheme is used to boot in BIOS mode.

It is an indication that you booted the Fedora installation media in BIOS mode instead of UEFI mode


Oh, wow, thanks for the hint. Sorry, do you have any link for further reading on how to boot the F35 installation media (USB device, in my case)?

Wiki is a start for me about the biosboot partition for me.

In order to boot Fedora installation media in UEFI mode:

  1. Use the UEFI boot menu (for some of my machines, press F12 during POST to access that). or
  2. Disable BIOS (legacy) boot mode in System Firmware, or
  3. Set Boot priority to boot UEFI device first.

F8 on many machines will bring up boot menu, F2 F12, DELETE will bring up bios/UEFI Menu wheere you can set the boot order etc

thanks everybody here! this helped and solved my issue.

1 Like