Fedora 40 server legacy bios


I have issue with fedora server 40 installation.
There is no “bios boot” partition in Blivet-GUI type partition selection.

When I try it in virtualbox there it is ok.

It is possible fedora was wrongly loaded with efi support instead of legacy bios. I don’t know if that is possible in fedora.

I have questions. Can you confirm that with efi support is not shown “bios boot” in menu?
And how can I force legacy bios in fedora?

I’m using fedora server 40 in usb key, copied by “dd” command.

According to my test, if booted in UEFI mode you can create an ESP file system, whereas if boot in legacy BIOS mode you can create a BIOS-boot partition. You need to select the boot mode in the firmware setup and boot menu.

1 Like

I think you mean bios setup by firmware setup. There is nothing useful in there. There is no uefi/bios option, only boot order (related with boot). I checked that many times.

And I don’t know which arguments I have to use in boot menu, if you mean by boot menu grub kernel arguments or other boot loader.

Thanks for confirmation of my first question.

No, I mean BIOS setup OR UEFI setup, that depends on the firmware you have installed.

Hmm, according this article, it should support uefi somehow, but without gpt.

But still I would like to have it on legacy boot, like it is currently (Now I’m using archlinux on it, but I would like something more stable for server)

I never flashed a firmware into it. I’m afraid it could brick it.

There is only one newer firmware mentioned:

You USB device can be booted in UEFI mode or BIOS mode, depending on which entry you select int eh boot menu. How to do that varies quite a bit between computers, so you may be able to find some information specifically for your computer. Or just look around in the setup menu.

The firmware was originally flashed at the factory.

In most modern bios there is usually a ‘security’ tab where secure boot can be enabled or disabled.

There also is usually a boot mode option where the user may select ‘uefi only’ or ‘uefi + csm’ mode (possibly ‘uefi + legacy’.

Selecting ‘uefi only’ forces the system to boot only in uefi mode.
Selecting ‘uefi + csm’ allows the system to boot in either mode.

If your system is set to ‘uefi+csm’ then at boot time with the installer usb the bios boot menu (often accessed with F8, F11 or similar) should provide a choice of regular mode (legacy) or uefi boot from that device. The mode chosen to boot the installer selects the mode used to install the OS. If you wish to install and boot with legacy (MBR) mode then boot the install media in that mode and it will allow the os to boot in MBR mode using the bios-boot partition. Note that the bios-boot partition must be the first partition on the drive and uses the first 1MB of space.

I would love to, but there is nothing in setup. Really nothing. I will try to look under functional keys. I haven’t tried them for a long time. Maybe there is something. I know how MBR works. I have done with this boot sector a lot of things.

And if even functional keys contains only boot order and enter to setup and nothing what would be uefi/bios related, is there some plan B? Is it possible to change it in grub kernel arguments?

I think the plan C is install it with efi…

Fedora loads the boot mode that is selected when initially booting from the install media. If your bios does not allow selecting legacy (csm/MBR) mode booting then there would be no way to boot in that mode after install. The bios determines the boot mode based on internal settings and the selected boot mode during fedora installation.

Once again, the bios boot menu where you select the device to boot from should show 2 different icons for the usb device, one plain and one marked with UEFI, if the option to boot in legacy mode is available.

Nothing. There is only F2 (setup) and F12 (boot order). And none of them has something to do with uefi/bios.

I even tried to set admin password to disable TPM in bios. Nothing. Fedora will always boot with no “bios boot” in menu. So I will have to use efi with mbr, even I’m not sure if it will work.


The Fedora default is always to use GPT whether UEFI boot or BIOS boot unless forced to do otherwise. If you do force it to use MBR partition table, you won’t be able to create a “bios boot” partition, and you won’t need it either even when using BIOS boot.

Like I posted and tried: Boot problems on Fujitsu Lifebook p701 / Installation / Arch Linux Forums my machine will not boot with gpt. When I selected gpt it never booted. And when fedora installation is booted, it will not allow in Blivet-GUI continue unless efi partition is mounted and I cannot do anything with it. So I cannot do anything else.

Normally I’m using grub2 + bios+mbr without efi with clean arch linux installation. But I cannot do it with fedora, it seems.

Added anaconda, bios, f40, installation

Removed virtualbox

Added blivet

If you boot the live system and run sudo ls /sys/firmware/efi what do you get?

Uefi and MBR boot are mutually exclusive. Your system boots in one mode or the other and they are not both available at the same time.

I just rebooted to be able to show what is available for bios settings on my system and the images are below.

The first two images are from the bios settings menu and show how to select booting with CSM enabled or disabled. With csm disabled the system will only boot in uefi mode. With csm enabled it can be selected for which mode to use for booting.

The next image is the boot menu selected with F11 on my system.
Note that item 4 and the last item are both showing the same usb device for booting, but item 4 says UEFI and the last does not but shows USB instead. If I were to select the one labeled USB: it would boot in MBR mode from that usb device. This is where the user selects the mode to use for booting from the USB device, and the mode selected here is the mode used to install the fedora OS.

It is understood that your bios may be different, but it is common for almost all modern bios to provide the option to boot in legacy/csm/MBR mode or to boot in UEFI mode.

I will try it when I come home.

In my notebook for work it is the same as pictures you posted, but not in this old machine.
If you are interested, I will take photos of all screens of the bios and boot order, when I come home.

Do that. Both for the current installed system and when booting a live system.

It slowly appears that your computer is from 2011-ish, thus when UEFI wasn’t that common. Perhaps your computer isn’t even UEFI capable, and if that is the case, there won’t be any UEFI mode to be selected.

Would you be installing on a blank disk or are there already data on it? In the latter case, check the partition table using for example fdisk. The first partition should start at the first Mib boundary. That is the same as the first partition starts at sector 2048.