Boot issue: system bootOrder not foud

Bye, everybody,
I installed fedora 30 via network and I have the following message at startup:

System BootOrder not found. Initializing defaults.
Creating boot entry “Boot0006” with label “Fedora” for file “\EFI\fedora\shimx64.efi”

I kindly ask for help in understanding and resolving

thank you

1 Like

Is it possible to boot the system?
Does the problem persists on reboot?
Check the output:

sudo efibootmgr -v

When I had windows in dual boot (Actually only use fedora) I experienced similar problems. I think that when loaded fedora with secure boot off and UEFI on I had to select something like “Select an UEFI file as trusted for executing” where selected the shimx64.efi file from fedora into the Bios option.

But every time I restarted, new entries was add in the boot menu every time, I consulted efibootmgr I could see up to 50-60 entries, the solution was load the authorized signatures for fedora in the Bios (in my BIOS MSI click 4 it was hidden in the windows 8 option whose entry was entry by disable by default, msi hade hidden the option “select signatures to be imported during the loading of the Bios” after I selected import global siganatures and everything worked well.

You should check into your BIOS, i think something similar is happening you.


1 Like

the problem persists at each reboot … I tried other distro: (debian stable, opensuse leap and tumbleweed, manjaro) but only fedora me highlights this problem.
thank you for your support, tonight I will post the output of the command that you have indicated to me. I hope with your help to understand what causes it and to solve it


Hi @cpu! Welcome to Ask Fedora! Please have a look at the introductory posts in the #start-here category if you haven’t had a chance to do so.

As for understanding goes, here’s some background info. Your computer uses UEFI boot as all newer computer do (as opposed to legacy/BIOS boot commonly used previously).

UEFI maintains a list of bootable devices and operating systems, you can see it either in BIOS/UEFI settings (usually under Boot or Boot Order menu entry) or by calling up Boot device selection dialog on your computer’s startup – or right from Linux using command @vgaetera provided for you.

The message you’ve posted looks like Fedora’s bootloader or something else during each boot checks this list, can’t find Fedora’s entry in this list and tries to add it (again and again, and probably without success). Though it’s interesting how are you actually booting if it’s the case ))

After looking at the output of the sudo efibootmgr -v we can try, for example, removing from this list wrong/erroneous entries (if we find any), manually adding correct entry for Fedora if there isn’t one – etc. But first we need to look at the output.

Are any of these distros still installed on your machine? Are there way other OS installed (Windows, etc.)?

Does Fedora boot automatically for you or do you have to press some buttons to boot it? Do you see grub boot menu with the list of installed OSes (if there are any)?


premise: thank you all because you are very kind and helpful

having said that on the PC I don’t have windows, nor the other distros because I’d like to use only fedora. the other distros I mentioned were installed on the same machine (hp laptop is 7/8 years old and has two video cards: intel and radeon) I am currently using uefi without active secure boot because I thought (but it is not) that the problem it depended on this (I had read it looking on the net).
I will post the command output tonight and I hope that with your help I will be able to understand what is wrong.

Thank you again

P.S.: I add that in my bios I can’t do much if I don’t enable or enable secure boot and enable or not enable legacy (if I don’t enable it it goes in eufi mode), I don’t have the possibility to do anything else.

1 Like

output efibootmgr -v it’s

sudo efibootmgr -v

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0005,3000,3001,3002,3003,3004,2001,2002,2003
Boot0000* EFI HDD Device (Samsung SSD 850 EVO 500GB) PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(1,GPT,2c40c601-c4a4-46ac-b50b-55305a7bb8ff,0x800,0x64000)RC
Boot0001* Fedora HD(1,GPT,2c40c601-c4a4-46ac-b50b-55305a7bb8ff,0x800,0x64000)/File(\EFI\fedora\shimx64.efi)
Boot0002* Fedora HD(1,GPT,2c40c601-c4a4-46ac-b50b-55305a7bb8ff,0x800,0x64000)/File(\EFI\fedora\shimx64.efi)
Boot0003* Fedora HD(1,GPT,2c40c601-c4a4-46ac-b50b-55305a7bb8ff,0x800,0x64000)/File(\EFI\fedora\shimx64.efi)
Boot0004* Fedora HD(1,GPT,2c40c601-c4a4-46ac-b50b-55305a7bb8ff,0x800,0x64000)/File(\EFI\fedora\shimx64.efi)
Boot0005* Fedora HD(1,GPT,2c40c601-c4a4-46ac-b50b-55305a7bb8ff,0x800,0x64000)/File(\EFI\fedora\shimx64.efi)
Boot2001* USB Drive (UEFI) RC
Boot2002* Internal CD/DVD ROM Drive (UEFI) RC
Boot3000* Internal Hard Disk RC
Boot3001* Internal Hard Disk RC
Boot3002* Internal Hard Disk RC
Boot3003* Internal Hard Disk RC
Boot3004* Internal Hard Disk RC

I noticed that at every restart or start of the PC the number after the word Boot increases by one unit … I don’t understand why…

sudo fdisk -l
Disk /dev/sda: 465,8 GiB, 500107862016 bytes, 976773168 sectors
Disk model: Samsung SSD 850
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 1455AE58-7B05-4F55-B03C-FC7AE7ED0E93

Dispositivo Start Fine Settori Size Tipo
/dev/sda1 2048 411647 409600 200M EFI System
/dev/sda2 411648 94783487 94371840 45G Linux filesystem
/dev/sda3 94783488 105269247 10485760 5G Linux swap
/dev/sda4 105269248 976773119 871503872 415,6G Linux filesystem

sudo lsblk
sda 8:0 0 465,8G 0 disk
├─sda1 8:1 0 200M 0 part /boot/efi
├─sda2 8:2 0 45G 0 part /
├─sda3 8:3 0 5G 0 part [SWAP]
└─sda4 8:4 0 415,6G 0 part /home
sr0 11:0 1 1024M 0 rom

I hope the solution is not to go back to legacy and turn off uefi …

thank you for your support

P.S.: I tried to change the order with: sudo efibootmgr -o 0001, 0000, 2001, 2002
and to restart but nothing … still gives me the error indicated in the first post

1 Like

I thank you, but with the first command I get this error:
sudo grub2-install
grub2-install: errore: /usr/lib/grub/x86_64-efi/ non esiste: specificare --target o --directory.

obviously I’m wrong something … :frowning:

1 Like

Try that @vgaetera say, but in case and only after that all thing that you did try it didnt work , you could try it:

  1. secure boot disable.
  2. Reset Bios security to factoray defaults or Load HP factory defaults keys

Edit: Is important you check the point 12 in the link above (in case your Bios works like in the link)

If an Operating System Boot Mode Change message displays, type the code shown, and then press Enter to start Windows.

*NOTE: *
Make sure you type the code correctly. There is no text field to see what you are typing. This is expected behavior.
You need type the code to change the secure boot to disable mode.

I think you skipped a step in disabling the secure boot, like I did wrong with my BIOS.


1 Like

Sorry, that method is a wrong way due to Fedora-specific GRUB setup:

I’ve just tested it and it actually breaks GRUB. :confused:
So, I had to use the GRUB prompt to boot the system and then restore it:

sudo dnf reinstall grub2\* shim\*

@cpu, perhaps your problem could be resolved with BIOS/EFI firmware upgrade.


in fact I was just writing that at dawn this morning before going to work I tried and it happened that it broke grub … I thought I had done something wrong and it comforts me that it happened to you too and this means that it does not I made mistakes :slight_smile:

I have no live available … and I thank you for telling me how to recover :slight_smile: I don’t think that for my PC they will still do firmware / bios updates … and in any case to do them I would need windows that I don’t have. at this point maybe it’s better if I disable eufi and I only use legacy with mbr …

thank you all for your support

1 Like

I tried, but nothing … the only thing I do not understand is because only with fedora does it so … :slight_smile:

thank you so much

It was also my case. :smiley: I had opensuse, manjaro, and they ran also with the secure boot enable what one i never hade disable until fedora :wink:. I feel sorry for you but it seems so much my problem was. (secure boot off and load default signatures was all than i did. in my case worked but it is not your solution so i hope you can find the right one)


1 Like

@xtym thank you very much for your availability :slight_smile:

1 Like

Here find it out someone had the same issue and they found diferents workaround

There are diferents for exempel one did

  1. Change Boot Mode from Legacy to UEFI
  2. Enable Secure Boot
  3. Go to Security → Secure Boot Mode → Select an UEFI file as trusted for executing
  4. Find and select grubx64.efi

You can read and check it out if you have energy :slight_smile:

1 Like

in my bios there aren’t these advanced settings … it’s very basic

Correct grub reinstallation method for EFI systems also documented in quick-docs:

@cpu, I would also try one more thing – though it’s chances for success are pretty slim.

I’d manually delete – well, basically all the boot entries you currently have, and then manually create a boot entry for Fedora. In fact, better to do it other way around: first test if you can successfully add new entry, then delete all and create one for Fedora.

  • To create new EFI boot entry you need

    sudo efibootmgr --create --label MyFedora --loader "\EFI\fedora\shimx64.efi"
  • Then verify you can see this new entry with sudo efibootmgr -v. You can distinguish your new entry by it’s label (“MyFedora”).

  • Then delete all the entries (one by one) using

    sudo efibootmgr --bootnum XXXX --delete-bootnum

    where XXXX is number from BootXXXX entry you want do delete.

  • Add new MyFedora entry again. Make it active (just to be sure) with

    sudo efibootmgr --bootnum XXXX --active

    logically XXXX here have to be 0000 for the only entry.

  • Check again output of sudo efibootmgr -v to verify you see just MyFedora boot entry, and it’s one and only in BootOrder.

  • Also take note of this (just in case).

  • Reboot and see if it makes any difference.


@nightromantic thank you very much for your availability, I will try and let you know :slight_smile:

1 Like

@cpu, you’re welcome! I’ll reiterate again, chances of this working are pretty low, in my opinion. Still it’s worth testing/trying.

Also can you please make a photo of the screen showing

It can be a Fedora bug (especially as you’ve said that other distros didn’t have this problem), it’s worth reporting, and photo of the screen can help developer better understand the problem.

1 Like

in my experience linux I have shot so many forums… but never in anyone have I been welcomed as here, in which I have seen much education and availability and for this I thank everyone and I am happier more glad to have chosen Fedora.

@nightromantic photo about problem

How can I use it so that it can be used by Fedora?

best regards