Boot issue: system bootOrder not foud

Well, I though about filing a bug, so that developers could look into it – if it’s some mistake in Fedora itself (or in some of packages/programs used in Fedora). But after some more websearch it looks like BIOS/UEFI problem (as @xtym and @vgaetera already pointed), and I see reports about same problem with Ubuntu and maybe some other distributions too.

Can you please check this – second – answer (and third too):

The first answer is basically the same as what @xtym suggested from the start, but here Xeno talks about HP notebook specifically. Please see if you have an option he talks about in your BIOS/UEFI settings.

After partially reading / partially looking through rather long bug @xtym pointed to and several other questions/answers about your problem I think that maybe it’ll be easier to just reinstall Fedora in legacy/BIOS (not UEFI mode).

There are some other hacks you can try (several are detailed through the RHBZ bug 1512410) – but they (1) may work or not work and (2) may need constant manual actions to maintain – after every kernel update, for example – so would be not very convenient in the long run.

From what I’ve read – and it’s largely a guess on my part, I didn’t find it written clearly – though Yves L’ECUYER did quite detailed testing you can see in the comments to the RHBZ bugreport – one reason for this behavior may be the UEFI of your notebook don’t want to boot Fedora’s /EFI/fedora/shimx64.efi file and instead boots /EFI/BOOT/BOOTX64.efi – which could be (not sure here too) a fallback bootloader, which keeps displaying the message you’ve reported and adding Fedora’s boot entries – which UEFI then again ignores.

Workarounds @xtym suggested and Xeno written for HP in the askubuntu link I’ve posted rectify this behavior on the UEFI’s part.

And it doesn’t look like something we can change from inside the Fedora.


thank you for your patience and availability, I’ll look at the link you have indicated and during the lunch break I took a look at this link (by @xtym ) : 1512410 – Fedora 27 fails to boot with EFI : BootOrder not found where some users have switched to packages of fedora 26, I quote comment:

"Hello all,
I was able to solve it by using the suggestion from Comment #18.
What I did:

rpm -e --justdb --nodeps shim-x64-13-0.7.x86_64
rpm -ivh shim-0.8-10.x86_64.rpm

After a reboot the system started without any problem.

Nevertheless I would be interested to know what is the source problem of shim-x64-13-0.7.x86_64.

Thank you all for the helpful comments."

probably it’s a problem of my bios and honestly, in my opinion, it makes little sense to use uefi without secure boot. also I don’t need endless partitions on the hard disk and I don’t need to boot from a disk bigger than 2 tb, so with this pc I can be satisfied to use legacy with mbr. it was just to understand… but maybe here we go beyond the possibilities of the software

thank you all for your support and kindness, I will continue to stay on this forum with pleasure and I will definitely ask for your support again

1 Like

Problem with this solution is that now F26 packages are no more available for download, at least not from public mirrors.

I’ve written my guess at where the problem lies in my previous comment. Of course, I’m not a developer, and I even haven’t tested this myself ) So it’s just this – a guess. We can test it on your notebook – but I’m not sure if we should waste your time on it.

In my opinion there’s one (strong? not so strong?) point for using it – from practical point of view, so to say – it’s a default now, and with majority using it and you using an alternative there’s more probability of you running into some issues because of it – and others having difficulty helping you because of it.

But again, if it doesn’t work on your machine… maybe you’re better of using old method. It should serve you well enough during lifetime of you notebook, and when you’ll get a new machine – you’ll use it with UEFI.

I’ve definitely used BIOS boot with gpt drives, and I’m quite sure (not 100% though) you won’t have trouble with > 2Tb drives if you have grub installed, and grub’s files are in the beginning of the drive. If you will reinstall Fedora in BIOS mode – don’t reformat you drive to MBR, leave it as GPT.

Feel free to ask, try to help others when you can – this is how it works :slight_smile:


you can do it ? obviously without partition efi right ?

of course!
thank you all :slight_smile:

I actually have a (quite old) HP microserver with 4 3TB drives in a software raid with GPT partitioning running in BIOS/Legacy mode. I wanted to say I haven’t tried >2TB drives – but I looks I actually have )

You don’t need EFI partition to boot in Legacy mode. Me personally – I maybe would leave it – just in case I’ll move this drive into UEFI machine someday. But that can make sense only if you use manual partitioning anyway. If you want to use automatic partitioning – do it, efi partition alone isn’t the reason not to do it.

1 Like

I am having the same issue as @cpu is having, wherein a fresh install of fedora will not boot, and boot loader claims that the boot order is not found. However, I am completely unable to boot into the drive that I have fedora installed on, even through selecting the drive manually in BIOS. I was attempting to establish a dual boot with fedora and windows, with both OSes on separate drives. On boot, the fedora boot loader will display “boot order not found” error, reset the system, and attempt a reboot, which will start the whole process over again. I previously had a dual boot with openSUSE established, which worked perfectly fine. Any advice on how to fix my current issue?

hi @edgaralleno

excuse for the late response, but I have “solved” (quotes are not a case) passed from uefi to legacy. I have no particular needs to necessarily have to use uefi and gpt. also to me with opensuse, debian, manjaro etc… did not give the problem that presents fedora.

a dear greeting

Take a look here: (final post)

It did the trick for me. Instead of updating/reinstalling grub it is enough to reconfigure it.

@przemhb thank you, I had tried this too, but without success.

It just worked instead of “MyFedora” the final boot entry of boot order num 0000 should have name “Fedora” , it worked for me on my hp notebook.