Kitty (terminal emulator) crashes on Fedora 36 Silverblue

[glfw error 65544]: Wayland: fatal display error: Broken pipe

I had this issue with the beta and tried the new OS version today but the issue persists. It happens when kitty is run in a toolbox or when it’s layered. The window opens just long enough to be visible and immediately crashes. I should have recorded more error output but I needed my terminal to work and didn’t have time to mess around with it today. I also tried to file an official bug but creating a Red Hat account and learning the Bugzilla interface just to file one bug with one project is too much for a Sunday.

On version 35, kitty works as expected when layered or when run in a toolbox. I’m using Silverblue with the nouveau driver and Gnome desktop. It all works fine until I rebase to Fedora 36. Thankfully rebasing back to 35 and reverting to a pinned version was possible. Similar bugs filed to kitty’s Github issues have turned out to be problems with Wayland itself or a compositor.

Has anyone gotten kitty to run on Fedora 36?

You don’t need a Red Hat account. You can use the fedora account you created under accounts.fedoraproject.org

You might just add an email there you want to use for bugzilla:
Fedora Accounts

Better search/ask your question under ask.fedoraproject.org