Fedora 32 pre-beta (including issues & workarounds)

Just a quick note to mention that Fedora 32 in its current pre-beta state generally runs well but has a few issues:

  1. gnome-shell crashes sometimes, bringing down all of Wayland (and everything running). Fixed!

  2. X11 can crash… due to color management? (Probably not a Fedora 32 specific bug.)

  3. Firefox on Wayland has issues being maximized when it is self-managed (with the toolbar off). Fixed! Seems to work now, as of Firefox 74.

  4. toolbox’s F32 container is still set up to pull from rawhide and there’s a key mismatch. Fixed! Run podman pull registry.fedoraproject.org/f32/fedora-toolbox:32 to pull down the new changes to the toolbox image and then create a new container in the usual way with the toolbox command.

  5. Firefox is still 72.0.2, yet 73.0.1 is the most recent release (as of 18 Feb) Fixed! Firefox is now 74 (which was just released)

  6. Editing network settings in GNOME Settings causes a crash (of Settings).

  7. Using the color picker (in Flatpak’d Hexchat or Firefox’s <input type="color">, but probably elsewhere) causes gnome-shell / Wayland to crash

    • This is probably related to a color picker portal from Flatpak?
    • Or it could be trying to do color picking in Wayland?
    • Not sure if it affects X11

I haven’t run into #1768278, but have hit #1801820, which also happens to be an accepted beta blocker.

The gnome-shell crashing bug was due to gjs. (It’s probably both #1768278 and #1801820 ?)

A fix has been found and published and is making its way through Fedora’s build system. At the time of this writing (morning of March 5), it’s still in testing and not in Silverblue yet. It will probably land today or tormorrow.

Follow the gjs page on bodhi for more info:

I haven’t seen any updates for any of the other issues. (At least landing in Silverblue, according to changelogs.)

It does seem like the F32 container has been rebuilt. Pulling the container with podman has brought down changes:

podman pull registry.fedoraproject.org/f32/fedora-toolbox:32

However, it still seems to try to pull from rawhide, so the issue hasn’t been solved yet. I guess for the time being, keep using Fedora 31 in your toolbox containers?

I’ve updated the original post with the current status of issues (mainly the gnome-shell/gjs crash). Additionally, I’ve added the Firefox issue where it’s a version that’s simply too old.

Are you by any chance also experiencing this:
Modifying network settings through gnome-control-center leads to a crash and generates a core dump

I also see the network settings bug. I’ve added it to the list above.

(And I’ve updated the list, as the latest update in Silverblue, with Firefox 74 seems to fix the window maximization issue.)

1 Like

Just a quick note: a few days ago I rebased my Silverblue installation to Fedora 32 tree. Had to uninstall rpmfusion-free Fedora 31 package and gnome-tweak tool. Performed rebase, restarted and everything worked. So far I have not encountered any issues yet. Gnome responds very fast/fluently. I am impressed.

I have noticed that due to old Silverblue install, my home path still points to /home/user instead of /var/home/user. I modified this manually now. (Was already changed on Fedora 31 installations.)

Update: All the bugs I’ve encountered have been fixed. Everything but the X11 crash seems to be fixed… and that seems to be an existing bug in Fedora — one that you might or might not even run into. (At least on Silverblue, with GNOME, in both X11 and also Wayland, I haven’t experienced it. I think it may happen to pop up in some non-typical configurations.)

I’ve updated the top post with all of the recent fixes too.

So, for everyone feeling a bit brave*, it’s probably now fine to upgrade Silverblue to Fedora 32 beta(ish)!

* …and Silverblue definitely helps one feel braver with updating to pre-releases. :wink:

Issue number 6 (Network settings not being applied) is still there for me.

Oh, drat. I didn’t test the network changes properly last night. I still see it here too. :frowning_face: I’ve updated the top post to undo the strikethrough. Thanks for pointing out my mistake!

1 Like

If you’re thinking of upgrading from Fedora 31 to the beta(ish) Fedora 32, you may want to keep your currently running tree, so it isn’t deleted by garbage cleaning. You can keep your current install by pinning it:

sudo ostree admin pin 0 

Just in case F32 doesn’t work well enough for you, you’ll be able to boot back into F31 or even roll back completely.


A testing version of gnome-control-center is available. This should fix issue #6. Please test and add karma!

Had a chance to play with the Silverblue 32 Beta yesterday. Overall really impressed with how smooth it runs and the new Gnome is slick. I had a couple of issues and was wondering if anyone else is seeing them:
1] I use Gnome online accounts to access a Nextcloud instance. This works well on Silverblue 31 but on the beta I can only sync files (Nautilus) - calendars and contacts do show in Evolution or the Gnome Calendar app as expected.
2] The beta does not seem to be able to mount a USB thumbdrive with msdos format. The drive is detected in the disks app where it is reported as unknown media, but does not show up in Nautilus. To be sure I installed exfat-utils fuse-exfat as layered packages but that didn’t help (and is not needed in 31).

Again all very cool - enough to make me want to switch back to Silverblue when 32 is released.

  1. I’m using Silverblue with Nextcloud right now. But I did have it set up before I switched to the F32 beta.

    • Calendar works here
      • I tested by adding an event in NextCloud. It showed up in the GNOME Calendar Flatpak from Flathub (version 3.36). I then deleted the event in the Calendar app and it removed it in NextCloud too.
    • GNOME Contacts is a problem…
      • 3.36 from Flathub isn’t working for any service here. I’ve also tried Contacts 3.34 from the Fedora flatpak repo. It also isn’t working (in the same way).
      • However, Contacts works from the GNOME nightly devel repo with NextCloud. So the problem is the app and the source it is from, and both Fedora 31 and Flathub’s Contact flatpaks seem broken? This looks like a pretty big bug. Hopefully it’s filed somewhere already.
    • Nautilus mounting works here
      • (I usually use the Nextcloud sync client. But tested Nautilus integration for this comment.)
  2. I have a USB stick formatted to FAT32 that I mounted perfectly fine. It stated “msdos” format in the UI. However, complete and working exFAT support isn’t shipped by default in Fedora just yet. Linux kernel 5.7 should change that. (The version of exFAT just recently included in kernels is old and doesn’t support real-world uses of exFAT. There’s new support landing in 5.7 that should support all exFAT drives. F32 Silverblue is currently on 5.6.)

    • For now, it’s advisable to use something other than exFAT if you can. If you need to exchange files with other people on other operating systems, FAT32 or NTFS is a good choice.
    • “Unknown media” in GNOME Disks means that the disk is partitioned, but the filesystem is unknown. Nautilus only shows recognized partition formats. This is expected without support.
    • Your exfat-utils and fuse-exfat overlays from RPM Fusion should work. But that’s probably not a Fedora or Silverblue bug. You might want to check lsmod and journalctl to see if they loaded fine, after you plug in the USB stick.

F31 with updated Contacts app (hence 3.36) here. Can confirm it hasn’t worked with Google Contacts for quite a while :frowning:

After re-basing my personal computer from Silverblue 31 to 32 I am getting results that line up more with you have seen @garrett. Not sure why I had issues, but my previous results were based on a fresh install (in a VM), not a re-based version running on a real PC, like I am testing on now.

  • msdos formatted thumb drive is readable (still requires exfat-utils fuse-exfat installed as you said, for now)
  • Evolution, gnome-calendar are working with Nextcloud calendars and tasks via GOA.
  • For me Gnome-contacts (3.34.1) is working with Nextcloud contacts. I don’t use Google contacts and it looks like I am on an older version (from the Fedora repo). Also have not fully tested syncing/updating contacts yet.


  • Gnome-todo is not working (still with Nextcloud sync). Hangs around forever after starting trying to load task lists and finally the app crashes.

Couple of general comments. With Gnome-tweaks now out-of-favour, having to manually setup auto-starting for apps (for example the Nextcloud client) is a pain. I also had RPM Fusion issues during the re-base as I use a number of layered apps from there. Deleting the repo and apps before being able to successfully re-base to 32, followed by a re-install of RPM Fusion and apps is also a pain.

If you’re using Evolution from Flathub, not working in F31 vs. F32 could be due to a mismatch in the evolution-data-server API from host to the flatpak. (However, I think the Evolution flatpak also ships its own evolution-data-server as a fallback, or something wacky like that.)

GNOME Tweaks isn’t out of favor. The extensions have just been moved to their own app. Everything else in Tweaks is still fine. Keep happily using it for all the additional tweakables. :smile:

When I’ve had RPM Fusion installed before, I had to do an rpm-ostree reset to remove the distro and overlay packages before doing a rebase… and then re-added. Agreed about it being a bit of a pain. At least RPM Fusion is becoming less needed over time?

As this is my work computer, I’m not so fussed about the lack of exFAT support. And the Flatpak version of official Firefox (on the Flathub beta channel), Kdenlive, and VLC and such all have proper codec support, so it isn’t a big deal to me.

On my personal laptop, however, exFAT support is critical for using some of my SD cards with my camera (which reformats SDXC cards to exFAT), so I’m also looking forward to the new kernel that will bring full exFAT support soon. A work-around is to reformat the SDXC cards to FAT32 ahead of time, as the camera still supports that too, but it’s something you have to think about and get right beforehand. I have RPM Fusion installed on it for that reason. (But my personal laptop isn’t using Silverblue, just “normal” Fedora 31, so it’s not as much of an issue there.)

@garrett thanks for the suggestions. I am pretty sure (don’t have access to the VM right now) I did install Evolution from Flathub - didn’t even think about that, and well spotted as a probable cause. Re Gnome-Tweaks I think I did mis-understand some of the messaging about that tool - after seeing your post I installed it and am happily tweaking Gnome again. I use exFAT for exactly the same reason - to read a card from a camera. Installing exfat-utils fuse-exfat (from rpmfusion) is a good workaround for me until we get kernel support.

After testing a bit more testing today I think the only issues I have left are:
1] Gnome-todo is unable to load task lists (local or remote). Looks like there are multiple open issues with accessing NextCloud tasks from this app: #310 and #305
2] I noticed the rpm-fusion repos I have installed don’t show up in the software app’s repos list, but I suspect (i don’t think it’s a bug?) things will change around that as we get closer to release.

Again, really liking the Silverblue 32 - so I am planning on staying on it - and will probably swap my work PC (currently regular Fedora) in the future.