Kinoite 35 pre-release>Type Chinese

Good day,

I’ve been running Kinoite 35 for some time already, but haven’t been able to type Chinese, no matter what I do on the Keyboard Layout setup.
I’m certain that I’m missing something because I don’t think I need to layer any language package, it wouldn’t make sense?

I would appreciate any hint on how to solve this issue.

Regards,
RR

1 Like

We’re still on the early days of Fedora Kinoite so we could definitely miss some packages for some specific configuration as I have not tested all input methods, etc. If you can figure out which package is missing compared to a classic Fedora KDE Spin installation that would greatly help and I would add them to Kinoite.

Can you also move that post to the Kinoite category? Thanks!

Moved for you @Siosm

1 Like

You need IME for chinese, right? I personally need it for japanese, im on silverblue, so its built-in Ibus in gnome. I tried getting advanced input methods (fcitx, ibus) to work in wayland outside of gnome a few times, but all in vain, doesnt seem like there are any working solutions.

Good day,

Apologies, didn’t know there was a Kinoite category before. Should have checked better. And I do understand Kinoite is still a ‘baby’ :wink:

Yes, as @nikicool pointed out, there is a need for an IME. On regular Silverblue, with GTK seems to be default, I mean, in the settings, just add Chinese input method [pinyin in my case] and that’s about it.

On Kinoite, as I’m using it as a clean install, instead of coming from Silverblue and rebase to Kinoite, not sure yet what is missing. Though most likely should be some ibus stuff. I say “not sure” because I can type latin based languages and russian, it’s with chinese the one with the issue.

Now that I think about this again, I recall that I experienced a similar issue before with other distros, and it was related to some ibus-table-pinyin not being installed, so even when adding the chinese layout couldn’t type chinese because the ‘ibus-table-pinyin’ wasn’t installed, or no ibus installed at all.

Also, not sure yet if Kinoite uses ibus or fcitx. Nonetheless, presuming ibus is the default input method in Kinoite, and ibus-table-pinyin is not installed, a question arises which is, should be default install, flatpaked or a layered package?

I’ll try to search and install the ibus-table-pinyin [should be ibus-libpinyin] to try to find out if this is the issue with Kinoite. Will report back.

Regards, and thanks!
RR

Can you try a classic Fedora KDE Spin and see if it works there?

Can you also open an issue in the KDE SIG tracker for tracking?

Thanks!

I think you will need to switch to Plasma X11, since ibus input is not working currently for Plasma Wayland. You also need to overlay im-chooser to enable ibus and then restart your session.
You can add the libpinyin IME inside ibus-setup if needed.

(If one is installing the KDE Spin, then it seems necessary to install ibus-libpinyin oneself (or one can add langpacks-zh_CN for more support.)

1 Like