The ibus input method cannot be used in some flatpak applications - kinoite

The ibus input method runs normally, but cannot input Chinese in some flatpak applications
Known unsupported applications include: brave, joplin

thanks for your help

Operating System: Fedora Linux 39
KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.113.0
Qt Version: 5.15.11
Kernel Version: 6.6.11-200.fc39.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 12 × 12th Gen Intel® Core™ i5-12400F
Memory: 62.6 GiB of RAM
Graphics Processor: NV168
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: H610M H DDR4
System Version: -CF

Kinoite (KDE): Chinese character input using fcitx5 works, as long as the system settings → virtual keyboard is set to fcitx5.
Silverblue (GNOME): Chinese character input works out of the box.

Thanks for the reply, I first installed the flatpak version of fcitx5 before, but it didn’t work, then I installed fcitx5 with rpm-ostree, it still didn’t work, maybe it was a bad profile, I deleted the fcitx5 config file now, installed it again with rpm-ostree, and this time it worked

rpm-ostree install fcitx5

rpm-ostree install fcitx5-autostart

rpm-ostree install fcitx5-chinese-addons