KDE Plasma 6.1?

Will Fedora 40 KDE get the Plasma 6.1 update or do we have to wait for Fedora KDE 41?

It started being built today for f40. See for example kwin | Package Info | koji

I assume that there will be the normal 2 week delay for testing then it should be in updates.

1 Like

It just popped up in discover for me a few minutes ago and I installed it - got a small crash message in a dialog window but it did run just fine and opened the welcome window, and even restored my session (a supposed new feature of 6.1) - let’s see I guess…

The update to plasma 6.1 just showed up for me today. But, unfortunetelly, it’s not working as expected.

When I try to update the system from Discovery, I receive a lot of error messages, regarding incompatibility between the current version of the installed plasma packages, and the new ones.

The messagem goes as follows:

file /usr/share/locale/ar/LC_MESSAGES/plasma_engine_keystate.mo from 
install of plasma5support-6.1.0-1.fc40.x86_64 conflicts with file
from package plasma-workspace-

Is basically the same type of error for more 34 files.

I hope it get’s fixed soon.

I updated yesterday to 6.1 for the wayland version.

Can you try the update from the command line and report any errors here please? sudo dnf update --refresh

I heard that
sudo dnf upgrade --refresh --allowerasing --best
solved this exact issue to some folks.

I did sudo dnf update --refresh yesterday.

The issue I think was largely people who still have X11 installed. They released the drivers for x11 yesterday.

I still do not see KDE 6.1.2 builds in Koji: kwin | Package Info | koji

Is there some issue?

BTW KDE Gear 24.05.1 was not released as well. Today was Gear 24.05.2 with important fixes to KCalc release. Will it be available in F40?


Is this thread now about 6.1.2 or individual issues?

Fedora Kinoite has Plasma 6.1.x for a while.

I think individual issues because of deviations from Fedora upstream should be solved in dedicated threads, as the answer to this one is “yes, it is there”.

Just asking, since waiting for the 6.1.2 update…