Issues in discover, cancelling download crashing the whole discover app

, ,

I don’t know can someone confirm is this problem happening to only me or there are other also facing issues like me.

I was downloading 2 apps in discover and i thought to cancel one of them and that app crashed. I thought it is a x11 issue i restarted to wayland but same issue after fully updated system still same this crash happen only if i cancel a app install or download it crashes. I have tried with both wayland and x11 but issue was same. So is this issue device specific or it is a kde issue or other distros also face this issue.

Are you installing repo packages, flatpaks or kde components?

It is same for all kind of apps i have checked 3times with snap flatpak and default repo rpm it is not depending on the app or what i am downloading like recently just yesterday i thought to download tux racing but then i thought not to download and i tap on the cancel and discover crashed. This is same even if you do a update. And cancel a single component like vim was updating i cancel that and discover crashed.

Seems Discover is not the best updater?

Please file a bug


Is this a fedora specific bug or a plasma discover bug.

Probably start with fedora.


Hey buddy i just tried on kubuntu same issue

1 Like