I am having a problem with my audio jack and mic and speakers

Hello Fedora or any contributor, I wanted to tell you that I facing an issue that my front panel of the audio jack and mic is not detecting in Fedora distributions from since the time when I installed the Fedora Linux the first and still I did not get the patch or fixation update after 1 year 6 months. Motherboard that I am using is msi A320M PRO-VH (Realtek based audio semiconductor). And also my bluetooth usb is also not working bluetooth usb that I am using is Enter E-UB5N Bluetooth V5.0 USB Dongle USB Adapter.

And the second problem is that I have installed Fedora on my friend’s laptop which is Infinix X1 Slim Series Core i7 10th Gen - 16 GB/512 GB SSD. The problem is that the the Laptop’s speakers and microphone is not working.

Unfortunately, the all problems that I have discussed we did not faced in Windows operating system.

We hope we will get an update as soon as possible. By the way we are using Fedora 37 (GNOME version of desktop environment) and also we have tried all the methods to fix out the problems but still we are facing an issue. If the problems will not fix or there are any paid method then please inform us, we will discontinue to use Red hat based linux distributions.

Thank you

If you need commercial, on-demand support from a distribution in the same general ecosystem, you need to look at Red Hat Enterprise Linux.

Fedora is a community-built and community-led project. Red Hat sponsors Fedora, but it is not a Red Hat product and Red Hat does not offer support for Fedora Linux. We — the Fedora community — offer assistance, suggestions, and fixes as best we can, but we can’t promise any resolution on any fixed timeframe, or guarantee hardware compatibility.

1 Like

I agreed but brother how can I fix the issue at least?
And also the goodwill of Fedora will ruin. Even I also loves Fedora but there are minor bugs which has to fix.

No it’s a request.

I had a similar issue once that I was able to resolve by passing some extra options to the sound driver. If you want to troubleshoot the problem, I’ll give it a try, but there are no guarantees that Linux will work with all possible hardware combinations.

What is the output of lspci | grep -i audio?

This is my PC’s information not my friend’s one.

[root@msi msi]# lspci | grep -i audio
30:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
30:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h/19h HD Audio Controller
[root@msi msi]#

How about lspci -v -s 30:00.6?

[root@msi msi]# lspci -v -s 30:00.6
30:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h/19h HD Audio Controller
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device 9c52
	Flags: bus master, fast devsel, latency 0, IRQ 58, IOMMU group 8
	Memory at fcd80000 (32-bit, non-prefetchable) [size=32K]
	Capabilities: [48] Vendor Specific Information: Len=08 <?>
	Capabilities: [50] Power Management version 3
	Capabilities: [64] Express Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

[root@msi msi]#

We integrate thousands of software projects and strive to produce a polished result that runs on a vast world of diverse hardware, including hardware where the manufacturer does not provide good support for Linux. Of course there are bugs. We do our best.

I know it’s frustrating to experience problems, but it does not help us help you to threaten about deadlines or reputational damage or whatever else. Please be patient, and we’ll do what we can.


I’m trying to find information about your sound card. But information about that device ID is scarce.

Try running the following command to create a /etc/modprobe.d/sound.conf file that will pass the dual-codecs option to the snd-hda-intel driver and reboot your PC. :crossed_fingers:

echo 'options snd-hda-intel model=dual-codecs' | sudo tee /etc/modprobe.d/sound.conf

FWIW, according to the spec page for your motherboard (A320M PRO-VH), your audio device is a ALC892, so if the dual-codecs option doesn’t work, you might experiment with other options listed under the ALC66x/67x/892 section here: models.rst - Documentation/sound/hd-audio/models.rst - Linux source code (v6.1) - Bootlin

1 Like

That is the point, using hardware designed for closed source operating system and then come to an opensource project ranting about hardware not working.
Better use the closed source OS then to have peace.

Can you please test an older Kernel to see if your hardware is recognized?

Does not working.

It seems to be like my problems will not go. I have an issue with my bluetooth USB also I am in just class XI so I need to study first. By the way, thank you for giving your valuable time. I hope the problem will be fixed in future updates.

Infinix X1 Slim Series Core i7 10th Gen - 16 GB/512 GB SSD
[infinix@infinix ~]$ lspci | grep -i audio
00:1f.3 Multimedia audio controller: Intel Corporation Ice Lake-LP Smart Sound Technology Audio Controller (rev 30)
[infinix@infinix ~]$

What is the output from this command?

sudo head -n 5 /proc/asound/card*/codec#*

[infinix@infinix ~]$ lspci -v -s 00:1f.3
00:1f.3 Multimedia audio controller: Intel Corporation Ice Lake-LP Smart Sound Technology Audio Controller (rev 30)
DeviceName: Onboard - Sound
Subsystem: Emdoor Digital Technology Co., Ltd Device 1a21
Flags: bus master, fast devsel, latency 32, IRQ 149
Memory at 6001130000 (64-bit, non-prefetchable) [size=16K]
Memory at 6001000000 (64-bit, non-prefetchable) [size=1M]
Kernel driver in use: sof-audio-pci-intel-icl
Kernel modules: snd_hda_intel, snd_sof_pci_intel_icl

[infinix@infinix ~]$

Sorry I did not tried this one.

No worries.

In case you haven´t noticed it, another user recently reported problems with a ALC892 codec. It appears that that particular codec has been particularly tricky to get working on Linux. There are links to some upstream bug reports in the other thread.


1 Like

:sweat_smile: Not working bro, by the way, thanks again. I have just informed the driver related things to this Fedora questionnaire sites make Fedora great operating system. I hope Fedora’s user experience will be on the apex.