Asus ROG Strix B550 - Front panel headphone\mic jack not working properly - ALC1220

First time poster, long time lurker here. I’m having issues with my front panel audio using Fedora KDE Spin on my new gaming build.

Let me explain my situation: my motherboard is equiped with onboard audio, it has the Asus S1220A codec, which is just a fancy name for the typical Realtek ALC1220 chipset. Anyway, this board has the usual 3 audio jacks in the rear (Line in, line out, mic), and front panel audio out. The front panel audio is connected to my case, which is the NZXT H210i. This case has a modern audio jack that works with smartphone headsets, but can also work as a simple audio out or simple audio in, if you connect a regular microphone or a regular headphone.

Now, my audio workflow is as follows, I have my big headphone permanently connected to the rear audio output as if they were speakers, and as needed, I connect a regular ol 3.5mm smartphone headset to the front panel, for example when I need to make a call with Telegram or whatever using my PC.

The issue: when I connect the headset, the operating system recognizes that something has happened. It cuts off the audio from the rear jack connected headphones, and in the KDE audio switcher, the microphone input appears, but I can’t hear anything out of the headset and the microphone doesn’t work.

If I go into the audio device settings in KDE, and I mess around with the controls for my audio output, I can get the audio working, but not reliably, sometimes I have to change the settings multiple times. But the microphone just doesn’t work no matter what. When I used Linux Mint, which uses PulseAudio, I still had issues with this front panel jack, it would not detect the headset, but if I ran a simple killall pulseaudio, it would restart and the headset would work. In Fedora I can’t get it to work unless I manually go inside the Audio settings in KDE and mess around.

Right now I can’t post logs and screenshots because I’m not on my main computer, I will post logs this evenings when I return home. In the meantime, has anyone faced similar issues with front panel audio on a similar system to mine? I searched the forums and google for a while, some people recommend using hdajackretask, but I can’t get it to work properly, at best I made it so that both headset and headphone would play at the same time (not ideal), but I still can’t get the microphone working.

Any help would be greatly appreciated, I think I found my endgame linux distro with Fedora KDE but this is kind of a showstopper for me. Just fyi, the headset and audio jacks work just fine in Windows even without installing the realtek driver. They also worked in Linux Mint when I was using that a few months ago (but I had to restart pulseaudio to get the headset detected).

Thanks in advance and keep up the good work.

Fedora now uses pipewire (with wireplumber) to handle pulseaudio, jack, and alsa.

Could you give us some more info about your machine by pasting the output of inxi -SMCIA (in preformatted or code block format)?

Hello. Here it is.

  Host: fedora Kernel: 5.19.4-200.fc36.x86_64 arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.25.4 Distro: Fedora release 36 (Thirty Six)
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: ROG STRIX B550-I GAMING v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2803
    date: 04/28/2022
  Info: 6-core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP cache:
    L2: 3 MiB
  Speed (MHz): avg: 2375 min/max: 2200/4650 cores: 1: 2200 2: 2800 3: 2200
    4: 2200 5: 2200 6: 2200 7: 2200 8: 3700 9: 2200 10: 2200 11: 2200 12: 2200
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.19.4-200.fc36.x86_64 running: yes
  Sound Server-2: PipeWire v: 0.3.56 running: yes
  Processes: 517 Uptime: 2m Memory: 15.53 GiB used: 2.31 GiB (14.9%)
  Shell: Bash inxi: 3.3.19

1 Like

Great. I suggest installing and running pavucontrol. Once installed are you able to see input levels for the microphone/headphone when plugged into the front in the Inputs and Outputs sections? You can also adjust specific volumes for these with that tool as well. (Even though it’s a “PulseAudio” tool, it still works normally with Pipewire as Pipewire handles the Pulseaudio protocol.)

The other thing I would suggest is that if you have a cheap pair where a microphone is built into some ear-buds, consider trying a different microphone that is separated out. Speaking generally, while those might work for cell phones, they can have weird behavior for other audio stuff (including in ear stage monitors, etc.).

Good call on pavucontrol, I almost forgot about it.
Anyway, I think I’m closer to the solution. On a fresh boot, if I just plug\unplug my headset from the front panel, it doesn’t work properly, plugging the headset into the front panel just disables the headphones connected in the back, like I described before. But if I go into Pavucontrol, and change it like this

It works just fine after that, including the microphone! Could there be a way to get this setting to switch from Line Out to Headphones automatically when I plug in the headset? Because every time I reboot, it doesn’t work again until I do that.

1 Like