No sound from speaker | Intel 6 Series/C200 + NVIDIA GK106 HDMI

The speaker is working. However, there is no sound. Moreover, I have experienced this on Ubuntu, Fedora, MX Linux and Manjaro. I tried many fixes. but it never worked. also after 5 or 10 minutes Linux freezes. Screen tearing happens. This happens on all distributions. I think I have a hardware problem.

Processor: i3 3220 3.3ghz

Graphics Card: NVIDIA GTX 650 TI BOOST 2 GB

Ram : Kingston 8 GB


Also, the speaker is not visible in alsamixer.

I will be very grateful if you can fix the screen freeze and sound problem. If it doesn’t I’ll have to go back to Windows :frowning:

Welcome to akd.fedora @cigkofte

Please read #start-here if you not had time yet.

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Feel free to use what suits you best.

I deleted Fedora 36 Workstation as it was corrupt. I’ll reinstall and post the inxi output here. Thanks for answer :slight_smile:


  Kernel: 5.19.16-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-36.fc36 Console: pty pts/0 Distro: Fedora release 36 (Thirty Six)
  Type: Desktop Mobo: ASUSTeK model: H61M-K v: Rev X.0x serial: <filter>
    UEFI: American Megatrends v: 0801 date: 07/21/2014
  Info: dual core model: Intel Core i3-3220 bits: 64 type: MT MCP
    arch: Ivy Bridge rev: 9 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 2472 high: 2695 min/max: 1600/3300 cores: 1: 2695
    2: 2694 3: 2694 4: 1808 bogomips: 26338
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA GK106 [GeForce GTX 650 Ti Boost] vendor: ASUSTeK
    driver: nouveau v: kernel arch: Kepler bus-ID: 01:00.0
  Display: server: X.Org v: with: Xwayland v: 22.1.3 driver:
    gpu: nouveau note:  X driver n/a resolution: 1440x900~60Hz
  OpenGL: renderer: NVE6 v: 4.3 Mesa 22.1.7 direct render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Device-2: NVIDIA GK106 HDMI Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.19.16-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.59 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: r8169 v: kernel port: d000
    bus-ID: 03:00.0
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.14 TiB used: 4.13 GiB (0.4%)
  ID-1: /dev/sda vendor: Western Digital model: WD10EZRX-00A8LB0
    size: 931.51 GiB temp: 31 C
  ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB
    temp: 29 C
  ID-1: / size: 228.63 GiB used: 3.91 GiB (1.7%) fs: btrfs dev: /dev/sda4
  ID-2: /boot size: 973.4 MiB used: 201.7 MiB (20.7%) fs: ext4
    dev: /dev/sda3
  ID-3: /boot/efi size: 598.8 MiB used: 13.9 MiB (2.3%) fs: vfat
    dev: /dev/sda2
  ID-4: /home size: 228.63 GiB used: 3.91 GiB (1.7%) fs: btrfs
    dev: /dev/sda4
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 44.0 C mobo: N/A gpu: nouveau temp: 35.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 1080
  Processes: 257 Uptime: 11m Memory: 11.63 GiB used: 2.24 GiB (19.3%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.2.1 Packages: N/A
  note: see --rpm Shell: Bash v: 5.2.2 inxi: 3.3.21

Please edit your last post, mark everything and click on the </> symbol for formatted text.
It makes the information more readable. Thanks.

I edited the comment

1 Like

Check on your motherboard bios, if you can select the Audio Card which you want to use by default.

If possible put it to Intel audio. Then the system should recognize it. This might help you that you can continue work with the Noveau drivers and have a working audio.

About your screen freeze, this is not up to us to fix it. This is your work to install the correct Nvidia drivers. Linux has an opensource driver for Nvidia named Noveau. Your system uses this and might not work correct with your Nvida hardware.

For this “freezing screen” there are tons of existing requests where you can have a look how to achieve an install from the official Nvidia drivers for Linux.

But with this request please let’s focus just on the sound problem.

Be aware working with Nvidia hardware and Linux you have regularly to reinstall the drivers because of kernel changes. Fedora changes quite often Kernel.

Have you tried a Linux-Mint/Ubuntu with LTS “long term version” for your computer?
They have a app explicit to administrate drivers. This is maybe easier for you if you are new in Linux?

1 Like

I have installed NVIDIA drivers. Worked ! The crashing is gone. When I entered the BIOS settings and set the HD option in the sound settings to AC97, the sound also improved. Thank you very much :slight_smile: Now I can use Fedora easily.

1 Like