USB Headphone still not working

I got very little response, when suddenly my USB headphone started making crackling and humming sounds. Now I am seeing many more users complaining about this issue. I wont bore you with the details, but it in this thread. I am having a problem with my audio jack and mic and speakers from February and the problem is still here today. Pipewire have put out a lot of fixes since , but it has not solved this problem.

The whole reason I came to Fedora was in the hope that this audio problem would be resolved with Fedora 37, but it was not to be. I thought Silverblue may be better and and I was fairly anxious to try it out anyway, so I installed Silverblue 37. Same problem. Incidentally, the same audio issue appeared for me on OpenSUSE and Tumbeleweed.

The best part of this exercise is, I have finished up being a firm believer in immutable images and run Silverblue37 as my daily driver. I just tested Silverblue 38 and the audio is still not working.

Of course, I have checked the motherboard and audio is definitely being output. I can live without sound on this computer, at least until the USB DAC reaches, but I still find this a mystery.

I also uninstalled Pipewire and installed PulsAudio, with the extactly the same results. The motherboard has USB headphone jacks on the rear and front. What else can I do to troubleshoot this issue?