I almost kept Silverblue this time

I really like the ideas behind Silverblue. I really want it to succeed. Whenever Fedora has a new release I install Silverblue and use it as my daily driver for a while. The first time I did that, several versions ago, I deleted it a couple of hours later and went back to using Arch. This time, I used it for a couple of weeks and almost kept it.

This latest version is very good. I’m impressed that even relatively obscure programs like “wavemon” are available in the repos. And using toolbox to isolate things really syncs well with my preferred workflow.

The problem for me, however, was video playback in Firefox. YouTube was fine. But even after installing ffmpeg-libs, playback on sites like odysee.com, nebula.app, and curiositystream.com was plagued by stutters and dropped frames. The Brave browser, however, worked perfectly. So I tried the flatpak version of Firefox from flathub. Slightly better, but still not smooth.

Out of curiosity, I installed Fedora Workstation. Same problems.

I installed Arch with Gnome. No problems. Videos ran smooth as silk.

Since Arch is still using pulseaudio, I suspect the problem with Fedora is pipewire. I read somewhere that F34 uses pipewire for video as well as audio. But I didn’t have the patience to do any testing, so I’m just guessing that might be the problem.

I hope Silverblue 35 will fix these annoying issues. I’m this close to switching over.

1 Like

I believe @gregoryhinton noted that was tried

1 Like

Thanks for the reminder.

1 Like

You mention installing ffmpeg-libs but did you install the actual ffmpeg from a place such as RPMFusion? Because that is what I had to do in order to watch any h264 videos. Firefox (and Fedora) provides openh264 but it is an older out-dated build that just isn’t up to the task. Apparently I’ve also layered packages such as gstreamer1-plugin-openh264 mozilla-openh264.

To test if it is a h264 &/ ffmpeg issue to these commands:

flatpak install flathub org.mozilla.firefox
flatpak install flathub org.freedesktop.Platform.ffmpeg-full
flatpak run org.mozilla.firefox

Then using the started browser view problematic sites and videos again.

Thanks for the tips, Joonas.

I think YT uses h264, don’t they? I never experienced any problems with YT, but sites like Odysee and Nebula always stuttered; I don’t know what encodings they use.

I hadn’t tried installing the full ffmpeg package from rpmfusion. Also, although I tried the firefox flatpak from Flathub, I didn’t install the ffmpeg-full runtime. Next time I test Silverblue I’ll try those workarounds if there are still video problems.

But I still suspect the ultimate problem may have been due to pipewire. As I said, on very similarly configured Arch and Manjaro systems the video always plays back very smoothly. Their kernels are compiled slightly differently than the Fedora kernel, of course, but the most significant difference I can think of is that those other systems use pulseaudio instead of pipewire.

I have three setups with full pipewire (no pulseaudio) on Arch Linux, classic Fedora and Fedora Kinoite (Silverblue variant) and all of them can play YouTube videos smoothly so I would suggest that pipewire is not the culprit here. I use ffmpeg from the RPMFusion repos on all Fedora installs.

Edit: Wanted to say not the culprit. Sorry for the confusion.

A followup with a happy ending…

In my last post I had scrapped Silverblue and installed Arch due to bad video streaming using Silverblue’s Firefox.

But after switching to Arch I ran into all kinds of problems trying to keep podman containers working reliably. Revisions to their packages kept breaking things. It became obvious that not enough Arch users were using podman to reliably test changes in their packages. Ugh.

So I decided to give Silverblue another try. My plan regarding previous Firefox video problems was to follow the advice of @jwnz : install the firefox and ffmpeg-full flatpaks from Flathub. But first, just as a baseline comparison, I installed ffmpeg from rpmfusion as a layered package and tested the standard Silverblue Firefox. To my great surprise, it worked great on all the video streams I could throw at it. No hiccups, failures, or stutters. I was ecstatic with delight.

So maybe the full-blown ffmpeg package was the missing element all along; I had previously just installed ffmpeg-libs. Or perhaps the Firefox or Pipewire packages got some critical fixes in the meantime. I don’t know exactly why the problem is fixed. I do know that I’m now a happy Silverblue user.


Definitely. There were a few rough spots (including some corner-case bugs after the F34 release) with PipeWire and it keeps getting better and better.

The latest release improved the quality of streaming from my phone (for podcasts, so I don’t have to have desktop and mobile apps and sync them), for example. And the release notes for 0.3.32 mentioned some improvements for Firefox specifically.


That’s great news. I’d wish that openh264 plugin for Firefox would be updated to a modern version with multithread decoding. Yet ffmpeg is the best one for mp4’s, it’s says so right in the tin.

Hello @gregoryhinton ,
It’s great that you were able to solve your issues with Silverblue. Could you please mark this as solved?

Just wanted to drop a note here that a) installing the ffmpeg package totally fixed the stuttering problems for me, and b) I did not have to enable the RPMFusion nonfree repository to get it. Just in case anyone else wants to avoid proprietary software as aggressively as possible!