Silverblue: Firefox cannot play Vimeo videos

Hi, I just installed Fedora Silverblue on my Workstation and while Youtube plays fine in Firefox, it does not seem to be able to play Vimeo videos. The JS Console shows “Uncaught (in promise) DOMException: The fetching process for the media resource was aborted by the user agent at the user’s request.” and “Media resource XXXXXXX.mp4 could not be decoded.” so it looks like a codec issue.
Any ideas on how to fix that? The problem is not present using Chromium.

I have used RPMFusion and rpm-ostree layered the non free ugly tainted codecs. Some of that runs Vimeo as a client playing. Joining Vimeo and providing content is probably working too, but I don’t have an account. They are not using ‘freedom’ cocecs. Not all of the dnf install commands translate (like group updateupdate multimedia) or will layer in Silverblue, but the non free codecs do.

Mine looks like this:
LayeredPackages: android-file-transfer epiphany ffmpeg fish gnome-tweaks gstreamer-plugins-espeak gstreamer1-plugin-openh264 gstreamer1-plugins-ugly htop libdvdcss mscore-fonts-all redhat-mono-fonts redhat-text-fonts rpmfusion-free-release-tainted rpmfusion-nonfree-release-tainted vlc
LocalPackages: rpmfusion-free-release-36-1.noarch rpmfusion-nonfree-release-36-1.noarch

They say the Flatpak Firefox ships with everything needed without adding or layering in things.

Check out Ask Fedora and post this question there. Maybe there is a more free option?
I just noticed Matthew Miller reminding us this: " This area is meant for discussion with and by the Workstation team about the development of the edition. Support requests should go to Ask Fedora. We have a plan to merge the two sites, which I hope will help with the confusion. In the meantime… the two sites do use the same underlying account system, so you should be able to log in and ask there with no problem."

I know this is an old topic, but I’m following a line of folks having issues playing Vimeo videos in Firefox, Fedora package, I’m a new user of Fedora 38. I tried various things to try to get it to work without any luck. I tried Google and that will play Vimeo, but I’ve grown used to Firefox. When I was looking around in the browser applications, I came across the alternative Firefox, Flatpak package, so I figured I had nothing to loose by replacing the Fedora version with the flatpak. Success! I see here that someone also suggested trying the flatpak version, and I’d have to concur.

1 Like