How to switch to AHCI mode from Raid on to install feroda 35?

So, I wanted to install fedora in my system with windows 11, so I created a 50 gb unallocated partition in my C drive. I prepared the bootable drive with ISO.
When I ran the bootable drive in UEFI BIOS mode, everything was working fine, but then when I selected to install fedora on a hard disk, it showed that “no local disks are available”.
I searched solutions on internet, and according to one article from feroda’s official site, I have to change Raid on to AHCI mode.
Now, the issue is if I change to AHCI, I will have to reinstall windows, which I don’t want to do.
So can anyone help me how to get over with this problem. I want to install fedora 35 with having windows 11 and without losing any data.

Strictly speaking, you will not lost data when switching from RAID mode to AHCI mode in system firmware.

What is lost, is the exist Windows installation will stop to be bootable.

There is a way to do the repair, but it is Windows specific, thus it will be better to seek help in a Windows forum or searching the Internet.

(But be aware, if you have disk encryption enabled in Windows, make sure you have the recovery key recorded somewhere. Just in case you might need it. Otherwise all data can be lost due to disk encryption.)


The place question is: why is your system set to RAID when you are not using a RAID system?

Since many of the newer laptops are set by default to RAID and delivered that way with windows installed this issue seems to be prevalent.

Was windows installed in UEFI mode or legacy mode? If uefi mode then installing fedora in uefi mode is fine. If it was legacy mode then fedora needs to be installed the same.

Looking at prior posts on this issue it seems a simple recovery boot with windows install media usually fixes it.
The steps IIRC are to switch the bios from RAID to AHCI, then do a recovery boot with windows so that the windows install boots properly. Once that is done then you should be able to install fedora on the unallocated space.


Windows is installed in UEFI mode, how can I install fedora in UEFI? Is it from Rufus as I ran the fedora media writer to install the ISO in my pen drive.

When installing from the USB, to boot in uefi mode from the USB there are 2 ways.

  1. set bios to UEFI only, and it will automatically boot with efi and install with uefi mode.
  2. While booting use the key that brings up the bios boot menu and select the uefi version of the usb device so it boots in uefi mode then it will install in uefi mode.

How you put the iso on the usb device is immaterial. You wrote the image there and it can boot. That iso is hybrid and is able to boot either legacy or uefi; it installs in the same mode as it was booted.

Not seeing the drive is a typical symptom of the bios raid config under which windows was installed.