How to re-enable secure boot on Fedora 38? - Solved

Finally took the leap and installed Fedora 38 Workstation as my main after using Windows 11 for a bit.

I installed Fedora 38 Workstation via the Ventoy USB method. (For this to have worked, I needed to disable secure boot (which had been enabled by default with Windows 11).

Oncee I finished installing Fedora, I wanted to re-enable secure boot. So I went back into my UEFI and did so. But, then I couldn’t get Fedora to start up. I was just stuck on the boot manager screen.

I was able to get back into Fedora by disabling secure boot in UEFI.

So, how do I fix this ?

My laptop is a Lenovo Thinkpad E14 2022 (Intel) btw.

I went back into the UEFI and enabled “Allow *Microsoft 3rd Party UEFI CA” and enabled Secure Boot. Then restarted and it booted back into Fedora.

Yes, you ran into one of those Microsoft designed security tools that seems to often block using other OSes on hardware sold with windows installed.

Glad you were able to find the way to bypass that lock.