Black screen until Fedora Lock screen

Hello, my machine is Lenovo P50 laptop. I’m using Fedora 26 as a Linux distribution (it is the first OS in the GRUB menu) and Windows 10 (as the next choice in the GRUB menu). I used such configuration for a long time but since yesterday, out of nowhere, when I press the power button on my laptop, the main logo of Lenovo and GRUB menu does not appear. The screen is black, turned off, until fedora is loaded (it is first choice in Grub menu and it is chosen automatically after 5 second I think). Fedora operating system works correctly. Moreover If I turn on laptop and hold down “Down Arrow” for 10 seconds and then press enter, then Windows 10 LOADS and I can see the Windows Lock screen and can log into the system. But let me stress that the screen appears to be OFF unitil Lock screen is shown.

Unfortunately for me, I tried to do fix this on my own and in Windows I used msconfig and set the Safe Mode option. Then I restarted laptop but now the screen is black constantly. The only thing I can now do, is to power my laptop and wait until Fedora 26 loads. If I do the trick with Down Arrow, Windows probably loads but the screen is black.

So my questons are as follows:
Can I from Fedora OS disable the Safe Mode for Windows ?
Can I use some commands in Fedora terminal to diagnose or bring back GRUB menu after laptop is powered on ?

Let me also add that connecting additional monitor does not work…

Please give me some hint how to get out of this madness.

Hi @kotu

Welcome to the Community.
Fedora 26 is no longer supported. Please get Fedora 31 now
Do it Now … click me


I’m personally have no other idea, but use the Fedora (can It mount the NTFS?) to backup your important files from Windows (preferable to elsewhere from the machine).

Then reinstall Windows (but their installers should have an “Restore” button).

Then use an Live DVD / USB to restore the GRUB. If your’re not willing to update the Fedora 26, try out Debian, Ubuntu LTS, Cent OS (dedoimedo have some tuturials to make an perfect desktop from CentOS), or even Trisquel (GNU! :wink: Beware).

Well for a bit more detail in guidance, I would do the following (if your machine is still in that state):
I would boot Windows with its installation medium (a DVD or USB), then opt to fix “what is preventing Windows from booting” or choose to “repair Windows” when the option presents itself.

After fixing Windows, boot it up, go to “Power Options”, and then disable “Fast Boot” – I learned that Fast Boot messes with the state of the drive – which may affect how Linux reads the drive too. After Disabling “Fast Boot” save the action and shut down. Then go to BIOS and disable Safeboot (but these days, it is not necessary to disable safeboot since recent Linux releases have decent UEFI boot support)

At this point you should use a recent Fedora media to install Linux. Fedora-31 is the recent release (not 26).

1 Like

Thanks for your advices. Actually I haven’t tried to use LiveUSB because I cannot access the UEFI (black screen, so no way to set up proper boot sequence options). I started to reading about setting up boot sequence from bash on my Fedora, but then another think came to my mind.
Having powering up the laptop I clicked ALT+CTRL+DEL a couple of times and guess what ? The Lenovo main logo appeared and then Grub menu was presented and I could normally choose either Fedora or Windows and everything is OK now. No more black screen during boot of the laptop.

It looks like UEFI somehow was frozen (hung) and ALT+CTRL+DEL restarted it. The cause of hung was probably either malfunctioned hibernation of Fedora or fast startup utility of Windows (rooting for the latter). If you have some other, better explanation of this situation, please share your thoughts.

EDIT: Maybe I should disabiguate what I mean that UEFI was frozen; i.e. the UEFI was not completely frozen because it was able to start the OS, e.g. Fedora. Rather there was something wrong with turning on the screen during boot and ALT+CTRL+DEL unblocked it.

There was something about hibernation issues in case of dualboot with Win’. Anyway… :slight_smile: