How to install fedora on MacBook?

Can’t install fedora 38 on my 2014 MacBook Air because of this error:

Why is this happening? Is there anything that I can do about it?

This seems to have been reported before, without anyone providing a solution:

Is fedora not supported on Macs? Or this a bug in the installer?

I seem to remember there was a thread some time ago where F37 and F38 would not install on the mac. The fix at that time was to install F36 then upgrade to F38.

Maybe you could do the same.

Maybe this one?

That doesn’t inspire a lot of confidence…

Remember that apple has tried to lock everyone out of using their hardware, including gpus with specialized drivers, specialized firmware, specialized and proprietary network cards, etc. All done with the intent to keep their hardware and software silo isolated from everyone else and force use of only their hardware and software as a set (and in the name of profit).

That the problem can be worked around is promising. How it is done may change over time.

Apple wishes to lock users into forced upgrades with new hardware sales required.

I have never used apple products because of the hardware and software lock-in and unreasonable prices.

It wasn’t always like this. But here’s what Woz explained:
Woz on Apple

I can Install Fedora 38 server and the special kernel available on Github on a 2018 13" MacBook Pro no problem.

That was the viewpoint of Woz. Apple has always been high priced and locked in for the hardware and software since they avoided the intel compatible processors for most of their production life.

Even the Mac with the intel processors are only now, after quite a few years with all other OSes locked out, finally having Linux becoming able to install and run on them. Proprietary hardware, proprietary drivers, proprietary bios, all designed to lock out the ability for users to install commonly used OSes.

Apple has had the closed silo environment locked down from the beginning.

From the beginning of being a successful company. In terms of profit. (When other Steve took control.) And even the Mac SE (that’s when Woz decided to go.) was sold with nice hardware manual, if You knew how to use soldering iron, screwdrivers and that special long Torx pole (I still have it) You could do a lot. I was upgrading ours all the way to system 7. And processor was nicely explained in book “Computer organization and the MC68000” (good book for general understanding of computer functioning).

So I have no clue if this is still ongoing but me and my friend got this same error and just made the partition (Its been a few months so I really dont remember the process). After I actually got it installed though my mac just straight up refuses to let me use it and the only things that actually work on it is most of the parts inside and the power button. I can use lspci to find my wireless network drivers but they just dont work on fedora. I have to use external everything pretty much and direct connection to my mac doesnt really work.

My ThinkPads have always been Linux-friendly, until the current one. I was unable to install either Silverblue 40 or Ubuntu 24.04 on my Gen 12 X1 Carbon. Perhaps Lenovo is taking some cues from Apple.

I used to run fedora 39 workstation without problems. When fedora 40 was released, I made the mistake of trying to upgrade (again to workstation version), and my macbook pro became unusable. The last time I tried (today), it became unusable after the dnf update completed. It started to give I/O error as to saying that for instance rpm was not found, when I tried to install broadcom-wl driver. (this may have to do with a sector error on hard disk but it worked before trying to do the update.)

Even though before the dnf update, it booted on command line only and without internet, after connecting to internet through USB and doing dnf update, it does not even start, neither in safe nor in regular mode, and only shows three dots.

Please note that this thread was related to fedora 38.
I suggest that you open your own thread on this issue since f40 is much different/improved from f38 and even though some things are similar there are many differences.

I am closing this thread.

1 Like