Issue installing Fedora while installing the boot loader

Error occurred when installing Fedora 37 on my Mac Mini (2011 using i7). Received the following:

"The following error occurred while installing the boot loader. The system will not be bootable. Would you like to ignore this and continue with installation?

Failed to set new efi boot target. This is most likely a kernel or firmware bug."

I am a novice at Linux, so please go gentle on me and make it easy to follow your fix. Thank you!!!


Supporting linux installs on older Apple hardware is difficult because Apple has made many changes to the EFI partition over the years. Linux installers may only support recent macOS versions (it would be nice to know which ones).

My iMac 14,2 (late 2013) ended up running Catalina after the SSD side of the hybrid drive failed last year. At that time, I installed Fedora 36. The upgrade to 37 came later.

It could be useful to know which MacOS version you have now and what the EFI partition contains. Given that you need to partition your disk to provide space for Fedora, you could try installing a recent macOS to the second partition.

Two groups that have insight in to Apple’s use of EFI are the hacktosh community and the project to allow installation of current macOS versions on old hardware.

There are several ways to examine your EFI partition

I experience the same error on Macbook Air 2013 when installing it over Fedora 36 as dual boot along with Big Sur being the last supported MacOS version. Fedora 36 did work.

1 Like

I solved the issue by the workaround:

  1. installation of Fedora 36,
  2. upgrade to 37 in Software Center app.
1 Like