Fresh installation wont boot on macbook9,2

Installed latest Fedora 40 Workstation on Mid-2012 13" MacBook Pro 13" with a Crucial BX500 SSD.

No dual boot shenanigans, let the automatic partitioning wipe the whole disk and let it install.
After the installation the system won’t boot showing:

Unexpected return from initial read: Not Ready, buffersize 0 Failed to load image: Not Ready start_image() returned Not Ready

Pretty much anything I’ve found on the internet relating to this had to do something with dual boot, hybrid MBRs, manual partitioning mishaps etc. - not useful

I booted from the install media again and chrooted into the installed system and tried to reinstall grub2. - no dice

I found out that some macs don’t like a fat formatted ESP. Formatted the ESP as Linux HFS+ and went on to reinstall grub. - also nope

Found out that there was a change from F37 to F38 that changed the installers partitioning behaviour on macs to use a standard fat ESP instead of the special Linux HFS+ macefi format.
Flashed F37 on a stick and tried to install again with automatic partitioning.
Anaconda threw this error at me twice:

Bootloader installation has failed: Failed to set new efi boot target. This is most likely a kernel or firmware bug

Only thing I could find on the internet is that “UEFI had run out of space?”.
Reset nvram and pram. - again dead end

[update:] the change was actually from F36 to F37. (misread that) Installed F36 without any problems and after installation it booted without any problems. Then I updated the system. Now I have the same problem as I had initially.

I’m kinda at my wits end here. Am I overlooking something obvious? Maybe the steps I already listed were the right direction but wrong execution/beginner mistakes?

Anyway. Here comes the wierd part. Right after the installation and the first time I saw the error message, after a few reboot attempts, I had just force shut the system down (long press on the power button, sometimes it would reboot automatically and sometimes stay off), it turned back on automatically. In that moment I hastily inserted the usb drive (with the installer on it) and pressed the option key (to get into the macs boot device selector) and it booted up, without showing the boot device selector (I was probably too late with the option key) and now I was in the freshly installed system.
I logged in, connected ethernet, ran updates and installed the proprietary broadcom wifi drivers.
Reboot, same error screen. After that while playing around I managed to get it to boot a second time by what felt accidental just like the first time.

Sometimes while playing around with rebooting it the error message would also change to:

LoadImage failed: Not Ready

Device path: "PciRoot (0)/Pci (0x1F,0x2)/Sata (0x0,0x0,0x0)/HD(1,GPT,4028EC96-757D-

02 01 0C 00 D0 41 03 0A 00 00 00 00 01 01 06 00

[update:] I just removed the SSD of one of my laptops with F38 on it and put it into the macbook. Booted without hiccup.

The reason why I was even doing a fresh install in the first place since the computer (formerly running pop os) wouldn’t boot anymore displaying a message that looked similar in content to the other error messages I got after the install (cant remember what it said exactly).

Is this a hardware issue? Is it the SSD that has gone bad?
[update:] I checked the SSDs smart status and there is nothing that would indicate a faliure.
Would have been suprised anyway since this is my moms computer and it gets very light use (user dir less than 60GB and the SSD was purchased new abt 2-3 yrs ago)

I’ll appreciate any pointers and advice I can get and thank you for your time reading this somewhat short essay of mine.

Removed f37, f38