How to install Citrix Workspace on Fedora 33

Hi all,

I wanted to share the following information to assist remote workers that use Fedora and connect remotely to their employers website. The steps worked for me using Fedora 33. This was performed on a clean Fedora install.

What is Citrix Workspace?

Citrix Workspace is a digital workspace software platform developed by Citrix Systems that allows multiple users to remotely access and operate Microsoft Windows desktops running in a datacenter or a public or private cloud, via devices located elsewhere.

Citrix Workspace app for Linux enables users to access virtual desktops and hosted applications delivered by XenDesktop and XenApp from devices running the Linux operating system. Workspace app for Linux is available in English, German, Spanish, French, Japanese, Dutch, Portuguese (Brazil), Simplified Chinese, Russian and Italian.

Disclaimer: I am not associated with Citrix, RedHat, or Fedora. This is NOT an advertisement. This is an attempt to share information on how to use Citrix Workspace with Fedora. This was written in hope to help others.

How to install Citrix Workspace on Fedora

Step 1: Download Citrix Workspace App for Linux

1a) Go to the following link to download the official Citrix Workspace app for Linux:

1b) Scroll down to “RPM Packages” then select "RedHat Full Package (Self-Service Support). Download the Citrix Workspace app for Linux by clicking “Download File”

1c) Scroll down to “USB Support Package” and download the package by selecting “Download File”

Step 2: Install the Citrix Workspace and USB packages

2a) Open a terminal and change directories to the Downloads folder then install the Citrix Workspace and usb packages using the dnf command:

dnf to install:

sudo dnf install ICAClient-<press tab to autocomplete>

2b) Install ctxusb next:

sudo dnf install ctxusb<press tab to autocomplete>

Step 3: Download your Employers Certificates:

3a) Go to your employers Citrix website

3b) View your employers Citrix certificates in Firefox by clicking the lock next to the address bar then selecting “View Certificate”.

3c) Download the “PEM (cert)” and “PEM (chain)” certificates.

3d) Switch to root user (or use sudo) and copy the .crt CA certificate files to /opt/Citrix/ICAClient/keystore/cacerts/ folder.

Step 4: Download the root certificate for your employers Certificate Authority

4a) Download the root certificate from the Certificate Authority who verified your employers certificates.

4b) Switch to root user (or use sudo) and copy the root certificate files to /opt/Citrix/ICAClient/keystore/cacerts/ folder.

Step 5: Run /opt/Citrix/ICAClient/util/ctx_rehash via terminal

5a) In a terminal run the following command to rehash the certificates:

sudo /opt/Citrix/ICAClient/util/ctx_rehash

Step 6: Launch the Citrix Workspace app and enter your credentials:

6a) Launch the Citrix Workspace app - the first screen will ask for your employers Citrix website

6b) The next screen will ask for your user name, password, and passcode. Enter your credentials then click “Sign In”.

That should be it - the steps above worked perfectly for me.


Citrix Workspace on Fedora

Citrix Workspace on Fedora 33


Appreciate the helping post. :grinning_face_with_smiling_eyes:

EDIT - I am surprised as to how there are no COPRs for an application as popular as Citrix, that the users are recommended to get RPM packages from a third-party website. There must be one I think but sourcing RPMs from a third-party website is just as much as looked down upon as adding unsolicited repositories.


Please change

sudo dns install ctxusb


sudo dnf install ctxusb


`sudo /opt/Citrix/ICAClient/util/ctx_rehash`


sudo /opt/Citrix/ICAClient/util/ctx_rehash

(Is this an automated post?)

1 Like

I lately saw this topic with an Nick name as somesitecom. This time he wants to say something new about (Dandified Yum) ?!

Could be a smart person behind or a smarter robot who was made by a genius :slightly_smiling_face:

I liked the content but will dislike it temporarily (to not promote a robot).

1 Like

Because it is proprietary and closed-source - not only is it not possible to build it without the source, it may not even be allowed.


Updated! thank you for your feedback

1 Like

Would it be worthwhile to make a quick-doc (section Adding and managing software) out of the write-up?
Not sure how many Fedorians actually use Citrix Receiver (I personally don’t anymore but it always used to be a bit tricky to get it up and running (F24-F28))


Yeah that makes sense. Even if one could be tempted to put their big bad compiled output of a file inside an RPM and shellscript to execute it, COPR states that the contents packaged should be allowed.

[If someone has questions on what all is allowed, please read these and Licensing:Main - Fedora Project Wiki]

+1 to this.

A quick-doc of it would certainly help someone it is supposed to.

That’s why I wished Syngrafias could have been a thing in the Docs workflow as that could potentially make documentation editing and collaboration accessible to even those who are not well-versed with version control and Antora.

Sad life.

Just wanted to say thanks for writing this little guide, got me up and running after I hit a certificates issue when trying to connect to a client’s infrastructure.


2 posts were split to a new topic: After an upgrade to Fedora 34 the mapped folder in the Citrix environment is not writeable anymore

Last year has been a pain running a VM only to interact with citrix stuff .

For me the missing part from previous attempts was the use of the USB-xxx rpm and the download and setup of certificates.

For what it is worth all I had to do was download and install the .rpm from citrix and install it.

Of course selinux did not like it so I had to add a policy:

ausearch -m avc -ts recent | audit2allow -a -M citrix
semodule -i citrix.pp

I have my users confined so the addition to the policy was:

#============= staff_t ==============
allow staff_t initrc_t:unix_stream_socket connectto;
allow staff_t var_log_t:file { open read write };
allow staff_t var_log_t:sock_file write;

I did not need to download or install the usb support package

I did not need to download any certificates, so skipped steps 2-5

Opened the client (search apps for citrix, added to favorites) → launch client → put in server url / ip address, the citrix client downloaded and installed the certificates

I entered username and password → got a blank white screen → added the apps I needed → works flawless on gnome .

For one of the apps I did have to set the time zone to the same time zone as the citrix server, but that was app specific.

Fedora 33 , gnome, wayland

I used to use Citrix client, so I made a package out of it: if anyone wants to take over maintenance, let me know: ICAClient.spec · master · Greysector / RPMs / ICAClient · GitLab . Latest version I packaged was 19.6.0. One of the changes probably required for F34+ is changing Recommends: alsa-plugins-pulseaudio to pipewire-alsa. This could be added to RPMFusion nonfree repo if someone obtained permission from Citrix to distribute the binaries.

1 Like

Closing, F33 is EOL.