How do I add an ipp: printer on F35 gnome?

I have an ipp://hostname/details url for a corporate printing service, how do I add that in Fedora 35 gnome? When I go to printers in the settings app, there is a button to add a printer, but that just brings upp a dialog that seems to search for lan printers or something. It does not find anything except for “CUPS-BRF-Printer”, which seems to be some kind of text-only fallback virtual printer?

There is also a text/search entry at the bottom of the dialog. I try entering the ipp url there, but nothing seems to happen. I have also tried to add just the hostname there, but still nothing.

Any hints?

Try to access this page locally:


Using network printers, did you see this already?

Thanks. That worked, but there is nothing in the gnome printer management dialogs that suggest that I should ignore those and use a local web gui instead, so that feels a bit strange.

Cups is Desktop Environment independent. You might check on the Gnome website if you can make a proposal for such a dialogue.