GNOME suspends after 15 minutes of user inactivity, even on AC power


Since Fedora 38, systems with the GNOME desktop environment suspend after 15 minutes of user inactivity, even when plugged in to the AC outlet. This affects new installs and some upgraded systems (depending whether you touched that setting in the past).

This is due to an intentional change. To give it a better visibility, and because it might surprise many users and consider it a bug, it’s documented here.

Note: Remote sessions might not be considered when GNOME tracks user activity. Graphical remote sessions might count as user active, but that depends on the session server. An SSH session is not counted towards user activity.

Note: Fedora Server ships a configuration override, which defaults to not suspending on AC power by default. In all other Fedora editions, the described configuration change should apply, as long as you have GNOME environment running.


You can check and configure your current behavior in Settings → Power → Automatic Suspend:

Please note that these settings are your personal configuration only. Each user can configure their own settings. And, most importantly, changes to these settings don’t apply to the login screen. If you’re at the login screen (e.g. after a system boot or a user logout), the default options are used (15 minutes timeout).

Adjusting the login screen

If you want to modify the login screen behavior, you can display the current login screen settings with this command:

sudo -u gdm dbus-run-session gsettings list-recursively org.gnome.settings-daemon.plugins.power | grep sleep

Which prints an output like this:

org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 900
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'suspend'
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 900
org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type 'suspend'

The sleep-inactive-ac-timeout is the Plugged in option and sleep-inactive-battery-timeout is the On Battery Power option. The number is the delay in seconds. You can configure the values like this:

sudo -u gdm dbus-run-session gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 1800

This sets the Plugged in delay to 1800 seconds, i.e. 30 minutes. You can use 0 to disable the automatic suspend completely. You can verify that the option was set by displaying the current values as described above.


This is to satisfy energy certifications. Automatic suspend when plugged in was enabled for a long time in GNOME already, but there was a local patch in Fedora that used to disable it. Since Fedora 38, that override is removed (except for Fedora Server).

Related Issues

You can discuss this topic here.