Gnome Software doesn't start

Hi there,

I am running Fedora Silverblue 33. For some time now Gnome Software doesn’t start if the laptop has been running for a while, as a quick fix I can reboot the laptop after which Gnome Software works again.

The behaviour sounds similar to Gnome Software does not launch but I don’t have pcsc-tools installed and /etc/fwupd/daemon.conf is already at EnumerateAllDevices=false.

journalctl -f doesn’t show any logs in between an attempted start of Gnome Software and the message Timeout was reached.

Unfortunately I don’t know where or how to debug this issue further and would welcome some help.

Best regards,

Same issue here, also on Fedora 33.

Did you manage to solve your issue?

I can’t really say that I have - but the issue is solved for me.

What has changed? Nearly everything:

  • I reinstalled Silverblue (as Rawhide) from scratch in order to change from an cryptsetup + lvm + ext4 setup to cryptsetup + btrfs
  • I lost most of my home directory due to me being stupid and not having cloud sync at the moment.
  • I learned how to use rpm-ostree reset and rpm-ostree and rebased from rawhide to Fedora 32 and again to Fedora 33 until gTile is available on Fedora 34.

Judging from that I would try wiping ~/.local and/or ~/.cache? In case you made important customizations I would back the folders up.

I would welcome the feedback if you stumple uppon a solution that goes into the right direction. In case switching to a fresh ~/.local and/or ~/.cache worked I would be interested in a more thorough investigation.

Thanks for the reply. I noticed that if I kill the gnome-software process, it will show correctly the next time I open it. I also had a lot of flatpak updates due to new nvidia drivers being released. I have the feeling it was somehow related…

I cannot deny it, but at least on my machine nvidia drivers could not have been the culprit - I got intel graphics on my machine.