Gnome Software crashes, doesn't open after update to Fedora 38

Gnome software crashes before fully launching after I updated system to fedora 38 (via gnome software). For a split second the window shows progress bar with “Downloading software catalog” and disappears then.
It shows me notification about crash:
I tried to reinstall it with

sudo dnf reinstall --repo=direct --repofrompath='direct,$releasever/Everything/$basearch/os/' gnome-software

but it didn’t help and outputs

Added direct repo from$releasever/Everything/$basearch/os/
direct                                                                                                                                                                           269 kB/s | 1.7 MB     00:06    
Last metadata expiration check: 0:00:22 ago on Tue 18 Apr 2023 11:26:26 PM CEST.
Installed package gnome-software-44.0-3.fc38.x86_64 (from fedora) not available.
Error: No packages marked for reinstall.

Neofetch about my configuration:

Does the following work?

$ sudo dnf clean all
$ sudo dnf update
1 Like

I had the same issue, if you try to run gnome-software from command line you may see the error.

The error I see was something like:

Glib:GIo: settings schema ‘’ does not contain a key named ‘show-only-free-apps’

Probably an issue with libraries versions, and next updates will fix I’m sure.

I downgraded gnome-software and now it works, now I have the update notification but won´t do it today.

WARNING. I did tried to update after the downgrade and somehow my OS got stuck on boot, the las line shows:

failed to start initrd-switch-root.service

I panicked, I boot from a live usb, started copying my home, and I saw a broken link /root/system-update, deleted it and reboot. Back to normal. It could be something else but now I’m back.


Unfortunetly did not do anything for me.

I wonder if you can “reset” the value?

$ gsettings reset show-only-free-apps


No such key “show-only-free-apps”
1 Like

Are you seeing the same error as Matias if you lauch gnome-software from the command line?

22:47:11:580 Gtk No IM module matching GTK_IM_MODULE=ibus found
22:47:11:974 GLib-GIO Settings schema '' does not contain a key named 'show-only-free-apps'
Trace/breakpoint trap (core dumped)

It looks like you’ve identified the problem. But I have no idea how to fix the schema or why it might be broken. Maybe someone else will chime in.

Edit: If you don’t get a response about how to fix it here in the next 24 hours or so, go ahead and file a bug report on



Found this on bugzilla, worked for me!


Yes, these two command also fixed the issue in my system.
In case somebody need those:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

And then this:

cat /usr/share/glib-2.0/schemas/ | grep show-only-free-apps

should output this:

<key name="show-only-free-apps" type="b">
1 Like

Maybe I was too fast to report it as a good fix as after clicking restart and upgrade in gnome software the laptop is stuck on boot screen.

Is there a broken /root/system-update symlink like what happened to Matias? If so, does deleting it fix the boot problem?

To be honest I’m not sure if I knew how to check it at this point.

All in all finally I decided to make a clean install from USB I didn’t miss too much data or settings of apps as most of that is inside services, clouds.

Compiling the schemas did fix the gnome-software crash issue for me. But in the next “restart & update” It stuck on boot again. Yes, there was this broken link on the root but I decided to reinstall 38 from scratch from a live USB. This broken link may be a symptom of a broken upgrade. I don´t know.

It definitely seems like something went wrong on upgrade for you both, but as you’ve both reinstalled, it’s almost impossible to tell what exactly it was (it rather sounds like the upgrade transaction actually failed somehow before reaching the schema recompilation or wiping the /root/system-update file) or what caused it :frowning:

Is anyone left who hit this bug and has not reinstalled the system yet? If so, we really need to see the logs from the upgrade attempt: you should be able to find them with journalctl, using the -b-N arg to limit messages to a single boot (journalctl -b-1 gives you messages from one boot ago, journalctl -b-2 gives messages from two boots ago, etc.) or the --since and --until args to specify a specific date/time range if you remember when the upgrade happened (e.g. journalctl --since "2023-04-10 18:00:00" --until "2023-04-11 11:00:00" or whatever). It should be relatively obvious when you find the right logs - there’ll be a bunch of stuff about updating from fc37 packages to fc38 ones.

Alternatively, if either of you can remember any particularly unusual packages etc. you may both have had installed, that might help figure it out. The most likely cause, I guess, is some kind of bad scriptlet bug in some package you both had installed.

1 Like

I’m rather a noobie linux user who copies a lot of stuff from the web until I get the result I’m satisfied with. I don’t know what is the hardware Matias uses but the most obscure things I had installed on my laptop were maybe:

  1. This thing to get fingerprint reader working:
    GitHub - uunicorn/python-validity: Validity fingerprint sensor prototype
    with a special fix based on this issue: Fix for "Fingerprint not working after waking up from suspend" doesn't work on Fedora 36 · Issue #127 · uunicorn/python-validity · GitHub

  2. I can’t remember the exact way I got my nvidia mx150 graphics card to work last time but from what I recall it was a painful process of trial and error. I’m actually unable to make it work now even with all the resources online.

  3. I was also using this thing for battery life: GitHub - AdnanHodzic/auto-cpufreq: Automatic CPU speed & power optimizer for Linux

  4. Don’t really know what else. Had some aliases in bashrc to combine commands, some nerd fonts. Many Gnome extensions. However Gnome Software did not work even when extensions were turned off.

I manage the computers for my family and one of the computers was experiencing this exact problem. I managed to fix gnome-software crashing on startup by running

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

But after clicking restart and upgrade in gnome software, the computer gets stuck on boot every time. Removing the /root/system-update symlink using a live ISO now lets the computer boot again.

I also found the logs of the upgrade attempt. I’m new to Fedora Discussion and Discourse in general. In what format should I share the logs?

After a quick look at the logs, it looks like PackageKit experienced a segmentation vault and generated a core dump at about 84% of the upgrade process. You probably need the core dump too, right? Again, my question is in what format should I share it?

Kind Regards,