Fedora freezes after updating software through the Software app (Fedora 32)

Okay, so this is a super annoying and possibly big issue.

For reference, I’m on a late-2015 MacBook Pro and I’ve tried over 15 linux distros and this is the only one that has given me a problem.

So, here’s how I found this issue: I downloaded Fedora ISO from the website, check authenticity, burnt the .iso to a usb, booted from usb, installed Fedora to hard drive. Before and during the installation, everything works just fine. After it boots back up from installing, Fedora performs great. The only issue, is the after I install, I go to the Software app and it says I have 34 updates I need to install. So I click “Restart & Update” and then it does its thing. The unfortunate thing is, after it is seemingly done updating, my screen goes black and stays that way indefinitely. I tried getting the gui to come up, getting a terminal; nothing. I can tell the screen is on, but it is completely blank.

I tried asking around on Reddit and no one seems to know the issue.

By the way, most of the updates are for getting Gnome up to 3.36.2, with a few misc updates and one OS update.

I also tried updating through dnf instead of through the gui software app, with no difference.

This obviously sucks. I essentially can’t use Fedora because the only way to make it work is to NOT update it. I hope someone important or involved enough can see this and help me troubleshoot.

Thank you.

Do you get the grub menu after powering up at least?
By the way, welcome to the Fedora Community.

Unfortunately, no. It seems like it goes black right after startup, this makes me think something may be wrong with the kernel. If I force it to shutdown (which I will inevitably have to do), and then restart, I have the option to change my boot device, but that’s it.

That’s how I’ve been able to install and reinstall Fedora a few times to try it again and again. (I’ve installed Fedora maybe 4 times hoping that I just got a bad .iso or something, but unfortunately, no, every time I update it has been the same). Keep in mind, though, that if I install Fedora and don’t update, restarting and everything works just fine. It’s just something with either the OS update or the numerous updates to Gnome 3.36.2.

(And thank you! What a wonderful Distro (apart from this issue))

You may be able to help us fix this issue.

Next time you install Fedora (do not update from “Software App” yet). Let us see your boot configurations. Then do:
sudo dnf list kernel

take note of the highest version of kernel you see in output or you could send that to a web-paste with:
sudo dnf list kernel | fpaste
then share the URL

then run
sudo dnf update --exclude=kernel*

If you are able to reboot, then the highest kernel in the repo really has a problem. Otherwise, it could be something to do with grub, graphics, etc. We need to eliminate the potential offenders systematically. In the end, we can reach a fix. We really want you to enjoy Fedora on that device.

1 Like

Thanks so much for getting back to me.

I have installed Fedora and ran the commands you provided.

Here’s the link from the kernel command: https://paste.centos.org/view/91f6b854

I’m updating through dnf now, I’ll reply with the results.

Using the command “sudo dnf update --exclude=kernel*” I was able to update and reboot successfully.

The only update currently showing in Gnome software is the OS update.

So, then, what does this mean? Is updating my kernel impossible?

Thank you!

Kernel Update refers to the Kernel and other updates associated with that. So it does look like Kernel-5.7.7-200.fc32 is not working out for you. It does not mean that you can never update the kernel. It could mean that there is a regression in Kernel-5.7.7-200.fc32.

Here are your options:

  1. File a bug report against Kernel-5.7.7-200.fc32 at https://bugzilla.redhat.com and cite your experience. Then follow through with the developers until they fix the issue and release another update
  2. Wait for another Kernel release and hope that it comes with the fix.

Thanks for your assistance. I have filed a bug report. Hope it gets resolved soon!

I too updated my Fedora 32 using the Software app and now am facing issues like: My system is freezing on opening applications such as: VSCode.

I have posted my issue and am waiting for it to get reviewed by a moderator.

Hello @snikhill Update by DNF is preferred. Read about that in What is the difference between updating using dnf and using Gnome Software?


Hey there @jwytycfmu - could you share the link to the bug you raised. I have exactly the same problem with Fedora 32 on Mid-2015 MacBookPro, and it also started back in July. I thought the macbook was acting up, but I’ve recently tried Ubuntu 20.04 on it, and it’s working fine.

I found 1875985 – F32, MacBookPro (2015) fails to boot after installing newer kernel(s) but it looks newer.