Gnome shell crashing at every first login session (then working again)

Hi All
Just upon upfrading to f40, I have started experiencing a weird behaviour by Gnome:

  • with every start up, after logging in for the first time, the Gnome shell immediately crashes and request to terminate the session.
  • being brought back to login, I access again and now it all works smoothly - only for the extensions having been disabled (I read that Gnome does it automatically upon crashing out of prudence)
  • hence every time I have to re-activate extensions again and then I can start working with my deskop

Has anybody any clue about it? It is so weird that Gnome crashes only at first login.


It’s (very likely) one of the extensions that are causing the shell to crash. Review their settings and Gnome should indicate which is not compatible. Disable it an login should work as normal.

1 Like

It could be helpful to have the inxi -Fzxx hardware details for your system and a list of the extensions you use. Upgrades often leave older packages. Here, a system installed at f38 and updated to f39 and then f40 has:

% dnf list installed | grep -E '\.fc3'
anaconda-user-help.noarch                            26.2-6.fc39                         @fedora
f37-backgrounds-base.noarch                          37.0.5-2.fc39                       @fedora
f37-backgrounds-gnome.noarch                         37.0.5-2.fc39                       @fedora
f38-backgrounds-base.noarch                          38.1.1-2.fc39                       @fedora
f38-backgrounds-gnome.noarch                         38.1.1-2.fc39                       @fedora
libx86emu.x86_64                                     3.5-4.fc39                          @fedora
openssl1.1.x86_64                                    1:1.1.1q-5.fc39                     @fedora
python3-multidict.x86_64                             6.0.4-3.fc39                        @fedora
python3-sphinxcontrib-applehelp.noarch               1.0.2-14.fc39                       @fedora
python3-sphinxcontrib-jsmath.noarch                  1.0.1-22.fc39 

You may find details of the Gnome crash using journalctl -b -1. Disabling extensions one by one may reveal the guilty extension, but your issue could be triggered by some combination of extensions.

First and foremost, I have tried to disable all extensions and reboot: confirmed, without extesions active at startup, the crash does not happen. Therefore, the issue is there.

This the output of the inxi command:

  Kernel: 6.8.9-300.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-34.fc40
  Desktop: GNOME v: 46.1 tk: GTK v: 3.24.41 wm: gnome-shell dm: GDM
    Distro: Fedora Linux 40 (Workstation Edition)
  Type: Desktop Mobo: Micro-Star model: B460M PRO-VDH (MS-7C83) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.40
    date: 12/04/2020
  Info: 6-core model: Intel Core i5-10400F bits: 64 type: MT MCP
    arch: Comet Lake rev: 3 cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
  Speed (MHz): avg: 800 min/max: 800/4300 cores: 1: 800 2: 800 3: 800 4: 800
    5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 69597
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA TU117 [GeForce GTX 1630] vendor: Micro-Star MSI
    driver: nvidia v: 550.78 arch: Turing pcie: speed: 2.5 GT/s lanes: 16 ports:
    active: none off: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 01:00.0
    chip-ID: 10de:1f83
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 23.2.6
    compositor: gnome-shell driver: X: loaded: nvidia
    gpu: nvidia,nvidia-nvswitch display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: HP 24er
    res: 1920x1080 dpi: 93 diag: 604mm (23.8")
  API: OpenGL v: 4.6.0 vendor: nvidia v: 550.78 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GTX 1630/PCIe/SSE2
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel Comet Lake PCH-V cAVS vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a3f0
  Device-2: NVIDIA vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
    pcie: speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa
  API: ALSA v: k6.8.9-300.fc40.x86_64 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.6 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8168
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: D-Link DWA-171 AC600 DB Wireless Adapter(rev.A1) [Realtek
    RTL8811AU] driver: N/A type: USB rev: 2.1 speed: 480 Mb/s lanes: 1
    bus-ID: 1-6:4 chip-ID: 2001:3314
  Device-1: Realtek Bluetooth Radio driver: btusb v: 0.8 type: USB rev: 1.1
    speed: 12 Mb/s lanes: 1 bus-ID: 1-3:2 chip-ID: 0bda:8771
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
    lmp-v: 10
  Local Storage: total: 1.78 TiB used: 25.34 GiB (1.4%)
  ID-1: /dev/sda vendor: Samsung model: HD103SJ size: 931.51 GiB
    speed: 3.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: Kingston model: SA400S37480G size: 447.13 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-3: /dev/sdc vendor: SanDisk model: SDSSDA480G size: 447.13 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-1: / size: 445.54 GiB used: 24.77 GiB (5.6%) fs: btrfs dev: /dev/sdb3
  ID-2: /boot size: 973.4 MiB used: 566.3 MiB (58.2%) fs: ext4
    dev: /dev/sdb2
  ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
    dev: /dev/sdb1
  ID-4: /home size: 445.54 GiB used: 24.77 GiB (5.6%) fs: btrfs
    dev: /dev/sdb3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: nvidia temp: 31 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 35%
  Memory: total: 16 GiB available: 15.55 GiB used: 2.96 GiB (19.0%)
  Processes: 390 Power: uptime: 3m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 50 Compilers: clang: 18.1.1 gcc: 14.1.1
    Shell: Bash v: 5.2.26 running-in: gnome-terminal inxi: 3.3.34

Also, this is the list of my installed extensions:

I have checked those extensions pending update and performed the action, but to no effect nonetheless. Still, the problems is with my extensions for sure (see my comment below).