Gnome-shell extensions all stopped working

Hi, I did a system update in the software center this morning and rebooted the system. After it came up, all the gnome-shell extensions are disabled. If I tried to enable them, they just went back to disable after I navigated away from the extension website. I don’t see any errors anywhere that I know of. Anyone seeing the same issue?


Hi @dewongway
Some of the gnome-extensions want you to restart before they show results.
If it persists you could try to remove and reinstall.

Hi Jaap,

I have removed all the extensions except for the Background Logo system extension because that’s not removable. I have tried rebooting the system but that didn’t help. The background logo extension just doesn’t get enabled.

I noticed that my gnome-shell is crashing but I have no idea why. I have uninstall every extension I have but that didn’t seem to help.

I have already had this problem after an update.
The Extensions module is disabled It must be reactivated.
I dont remember how to access this module (ajustement or Extensions via Gnome-software

i meant “download Extensions module via Gnome software”

Hello @dewongway ,
Try gnome-shell-extension-prefs in a terminal.

@jakfrost @newsnews,

Thanks for the tip. When I tried the gnome-shell-extension-prefs it redirected me to install the Extension flatpak software in Software Center. So I installed it from the Software Center. It did allow me to enable the extension. However, my gnome-shell continues to crash and I’m not sure if it’s related to the extension or not. The only extension I have is the Applications Menu extension. It’s the system extension that comes pre-installed with the OS installation. I uninstalled it, reinstalled it, and used the Extension software to enable it. The gnome-shell crashes quite often and it killed all my running applications.

You can turn on debug with gnome-session --debug. It seems to place the session into debug mode, I tried it and when I used <ctrl>C to exit it, my session exited :man_facepalming:! Now to find the logs, I think journalctl will be able to access them you just have to grep it for gnome-session, or crash?

@jakfrost I couldn’t get the gnome-session --debug to work properly unfortunately. I did find more details in the problem reporting UI which shows the crashed thread and some of the libraries it called. I’m suspecting it has something to do with the video driver.

Yes, they can be problematic for sure.