Gnome Settings: Test Output not working

Why is in Gnome Settings testing the output device not working?
Reproducible: Start Settings, click Sound, in section Output click Test, in the appearing requester click either button for Front Right or Front Left → You will not hear anything.
Feels like a regression, b/c it was working until ~ 9/7/2022. One of the following updates introduced that bug.

pipewire --version:
Compiled with libpipewire 0.3.57
Linked with libpipewire 0.3.57
Gnome Version: 42.2

Which part of gnome are you showing as 42.2? I see various parts ranging from 42.0 to 42.4, and gnome-shell is 42.4 on my system.

The sound output is not likely related to gnome, but rather pipewire & wireplumber.

Some install pavucontrol and find settings inside that resolve their sound issues. Often with some outputs muted that should not be.

Hi Jeff V,
Thank you very much for your reply!

  1. I’m showing version 42.4 for the Gnome application Settings. I’m aware that there are multiple modules of Gnome but I just don’t know whether or how Gnome Settings is modularized.

  2. Sure. Sound itself is not the issue. My Fedora 36 system plays sound, e.g. with Rhythmbox. However, as soon as you click at the sound category from the long left side of Setting’s application window. The sound/music stops. That stopping I’m only now finding out, thanks to your question.

My original report is simply about the Output Device part of the Sound category in Settings as it is not producing sound anymore. It did so until last week and then it presumably fell victim to some faulty update(s).

  1. pavucontrol sometimes can be helpful but not with this issue.

Thanks again,

Thanks again Jeff,
What I have called Gnome Settings …

  1. … does not show its name in the about section,
  2. … starts when you click the upper most right part of the Gnome desktop,
  3. … also starts when you put gnome-control-center as a command in the terminal,
  4. … returns “gnome-control-center 42.3” when you put gnome-control-center --version

As someone not used to Fedora I’m sorry for not giving the correct name of the part I am reporting about. Perhaps it would be a good idea to specify the name of what I called Gnome Settings in the about section along with the correct version number of it.


Don’t feel bad about my questions. It is important that I understand the details so a good answer can be developed. Your explanation cleared up the questions so no problem there.

The initial question then is about why the test output from the speakers in the settings control panel does not work, even though you get an output when playing audio using rhythmbox.

From that same location in the settings control panel, what is selected for output device? Do you have one or more choices for output device?

There are others with more expertise than I with audio so I will allow one of them to jump in here.

No worries.
I only have one option to select from and that is the internal speaker (“Speaker - Tiger Lake-H HD Audio Controller” as I’m using a XPS 9710).