Global audio volume control does not work

I have issues with controlling sound volume on Fedora 39 with Gnome. I can change the volume per application but the global volume control is beeing ignored. I can mute all sounds but that’s all I can do. This affects multiple applications like web browsers, system sounds and the Orca Screen Reader.
Also, applications can control the per application volume. If I change the volume in Youtube for example, that change is reflected in my settings for Firefox or Chromium. Although that might be normal behaviour and I just didn’t know.

I haven’t made any changes to my Fedora installation. I also didn’t make any changes to my audio settings.
Here are some information about my system that might be useful.

uname -a

Linux CK-NB 6.7.5-200.fc39.x86_64 #1 SMP PREEMPT_DYNAMIC Sat Feb 17 17:20:08 UTC 2024 x86_64 GNU/Linux
pactl info

Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 243
Tile Size: 65472
User Name: christian
Host Name: CK-NB
Server Name: PulseAudio (on PipeWire 1.0.3)
Server Version: 15.0.0
Default Sample Specification: float32le 2ch 48000Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_72_00.6.analog-stereo
Default Source: alsa_input.pci-0000_72_00.6.analog-stereo
Cookie: 34f5:7020

Are you using PAVUCONTROL to do the per application volume or something else?

I use the settings application that comes with Gnome. I did try pavucontrol to see if it can fix the issue but it behaves the same.