Firefox can't mute or control volume

So, this hardly seems like a Fedora-specific question, but then again, I’ve never had this issue (not even earlier today, before installing F36) on different distributions, or Windows for that matter.

I figured it’s more related to the Fedora defaults than even FF itself, so this should be the proper place to ask.

The issue specifically is that I can’t mute anything on FIrefox, or control volume - muting tabs does nothing. Twitter videos play audio as soon as they’re in frame (as if the volume control didn’t exist, basically). Visiting spooked me a little bit - all of these demos played in the background at once, it’s not a pleasant sound lol. Now I can’t get them to play at all, having disabled autoplay in settings.

Has anyone had this issue before? I haven’t been able to find any thread here or elsewhere with the same problem. It’s probably related to how audio is handled by default in Fedora; I’m not sure what information about my system I should give.

I had this issue earlier this week, but after a update+reboot, everything was back to normal again. Probably it was just due to running dnf update without a reboot.

1 Like