Get h.264 to work on chromium

hey, i followed this website https://medium.com/@alex285/how-to-enable-h-264-on-chromium-on-silverblue-6ca8058a6a27 to get h.264 on chromium to work, but sadly:

error: Could not depsolve transaction; 1 problem detected:
0. nothing provides chromium-libs(x86-64) = 71.0.3578.98-3.fc30 needed by chromium-libs-media-freeworld-71.0.3578.98-3.fc30.x86_64

is there maybe another way?

Hello.

This is a recurring problem, in all versions of Fedora, not just Silverblue. Unfortunately, there seems to be no tune-up between Chromium maintainers and of libs-media-freeworld.

Usually this problem persists for 48 hours or less. Please try again in a few hours.

If playing such media is really urgent for you, you should try installing Firefox Nightly on flatpak, from here: https://firefox-flatpak.mojefedora.cz/

btw you can just install ffmpeg and have at least Firefox to work on h.264 …and for some weird reason Chromium also plays videos that wasnt playing before, even if h.264 isnt enabled

oh and also have the same issue with freeworkd! just tried it and then i saw ur post :slight_smile:

easy way to check
https://www.youtube.com/html5

Yes, it is also a solution. However, if it is to use Firefox, why not install the Nightly version in Flatpak, which is perfectly usable and comes with all codecs included?

because @fishxz looks like he’s using Chrome so Firefox i guess is a temporary solution till Freeworld is fixed on RPM-Fusion. plus we may need FFMPEG package anyway for various scripts, so why to install Flatpak Firefox (thats FFF? :p) that is already on core image …just for few days?

Yes. Thinking like this, it’s a good idea to have ffmpeg installed.

My reasoning is: if it is temporary, better install Firefox Flatpak, which does not change (again, more) the pure image of Silverblue. Right? :wink: