Funny behaviour when switching workspaces

Hi community!

I’m enjoying a freshly installed Fedora 34 with GNOME 40. According to the welcome page of the latter, you can switch workspaces with Super + Alt + Scroll. In my system, for some reason, that doesn’t work. What works is Super + Middle click + Scroll. Funny.

I can’t seem to find a setting to change this behaviour. How can I (re)set the originally intended behaviour?


Hi @samuel,

I am quite intrigued to know, how you perform a Middle Click and Scroll at the same time.

Please check if the following screen from Tweaks can be of any help.

Hi @t0xic0der !

The corresponding screen in my tweaks looks exactly the same! Doesn’t seem to contain any option to change the described behaviour.

And yeah, it works just like that: Middle click (pressing the wheel down) and scrolling before releasing the wheel again. But not Super + Alt + scroll…

1 Like

Actually, maybe the simple reaosn is that Super + scrolling just works (for me). So it does not mattter what you do in addition to that… :wink:

1 Like

:smiley: Talking about Occam’s razor… You are right! That works!
But it only works if my cursor is on the desktop… If it is on a browser or another program, it tries to scroll instead. Does that happen in your case as well?

Go to the applications overview (super+A). On my laptop touchpad, super+(2 finger scroll
left and right) moves view left & right . Open Gnome help and click Start applications (for example). Now super+scroll left and right. When done, double tap while releasing super. As indicated by @slopez, on desktop, move to left/right workspace.