Flatpak fedora platform update error

Hi there,

for a few days now I run into this error when trying to update flatpaks:

flatpak update
Looking for updates…


        KENNUNG                             Zweig          Op          Remote          Download
 1. [✗] org.fedoraproject.Platform          f36            u           fedora          74,6 MB / 662,3 MB

Error: fedora: manifest hash in downloaded content does not match ref runtime/org.fedoraproject.Platform/x86_64/f36
Updates complete.
Fehler: There were one or more errors

Software shows the same error.

I added the flathub remote, but I don’t think it is responsible for the error, since the update is looking in the fedora remote.

Name    Optionen
fedora  system,oci
flathub system

I already tried running flatpak repair.

Here is the info of the installed version:


Fedora Platform - Shared libraries

     Kennung: org.fedoraproject.Platform
         Ref: runtime/org.fedoraproject.Platform/x86_64/f36
 Architektur: x86_64
       Zweig: f36
     Version: 36
     License: GPL-2.0+
    Ursprung: fedora
Installation: system
 Installiert: 2,0 GB

      Commit: de18dc189f2aab2f52afbeb84d37b4a326e946d3935486e0242a9b37f48966bd
     Subject: build of runtime/org.fedoraproject.Platform/x86_64/f36
        Date: 2022-05-17 08:52:25 +0000
      Alt-id: fdd65b15beb51ec4c295b30487752d046660e932976c4a45be78b03ff5141626

I am a bit lost on how to deal with this, since I do not have a lot of experience with flatpaks

Hello @karl2 ,
Welcome to :fedora: discussion!
You can try sudo flatpak repair to repair any errors with your current flatpak installation.

Thanks for the hint on trying the repair with sudo, sadly this leads to another error:

[sudo] Passwort für karl: 
[174/174] Verifying flathub:app/org.gnome.gitlab.somas.Apostrophe/x86_64/stable…
Checking remotes...
Pruning objects
Erasing .removed
Reinstalling removed refs
Fehler: Kindprozess »dbus-launch« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)

Turns out it is a bug (found this discussion today): Failed update flatpak org.fedoraproject.Platform - #7 by mateusseiboth - Ask Fedora