Flatpak error: No such ref 'runtime/org.fedoraproject.Platform/x86_64/f34' in remote fedora


I’m using Fedora Silverblue 35 and since yesterday I suddenly can’t use registry.fedoraproject.org for flatpak anymore. It fails with these errors:

martijk ~ $ flatpak update 
Looking for updates…
error: No such ref 'runtime/org.fedoraproject.Platform/x86_64/f34' in remote fedora

martijk ~ $ flatpak install transmission
Looking for matches…
F: An error was encountered searching remote ‘fedora’ for ‘transmission’: Unable to load summary from remote fedora: Failed to update OCI summary: Need more input
Similar refs found for ‘transmission’ in remote ‘flathub’ (system):

   1) app/com.transmissionbt.Transmission/x86_64/stable
   2) app/io.github.TransmissionRemoteGtk/x86_64/stable

Which do you want to use (0 to abort)? [0-2]: 0
error: No ref chosen to resolve matches for ‘transmission’

martijk ~ $ flatpak list --all --show-details  | grep f34
Fedora Platform	Shared libraries	org.fedoraproject.Platform	34	f34	x86_64	fedora	system	org.fedoraproject.Platform/x86_64/f34	26a086db517f	?	2.0 GB	system,alt-id=53b1b843cc06,runtime

The configuration in /var/lib/flatpak/repo/config is untouched. I’ve tried rebasing to Fedora Silverblue 34 and I’ve tried flatpak repair, both to no avail. If I install Silverblue in Boxes it works just fine on both 34 and 35 (the commit hash is different for the runtime, though). I didn’t change any system files, just installed some flatpaks and a few seemingly unrelated overlays. Any clue on what is happening here?

martijk ~ $ rpm-ostree status
State: idle
● fedora:fedora/35/x86_64/silverblue
                   Version: 35.20211002.n.0 (2021-10-02T08:08:26Z)
                BaseCommit: 605365ec671cb5cd6a616e507dbc2c60920ed633f07f6fe6f80fcf6718cc8471
              GPGSignature: Valid signature by 787EA6AE1147EEE56C40B30CDB4639719867C58F
           LayeredPackages: intel-media-driver gstreamer1-plugins-bad-freeworld gstreamer1-libav ffmpeg-libs vim gstreamer1-plugins-ugly tilix gnome-tweaks fontconfig-enhanced-defaults raw-thumbnailer
                            gstreamer1-plugin-openh264 openh264 mozilla-openh264 libva-utils gstreamer1-vaapi
             LocalPackages: rpmfusion-free-release-35-0.2.noarch rpmfusion-nonfree-release-35-0.2.noarch

                   Version: 34.20211003.0 (2021-10-03T00:46:45Z)
                BaseCommit: 03dbc7a6cdaddba4a047629f5472fc46c0e4cb96f60e44202d65ac9038b97aa7
              GPGSignature: Valid signature by 8C5BA6990BDB26E19F2A1A801161AE6945719A39
           LayeredPackages: intel-media-driver gstreamer1-plugins-bad-freeworld openh264 mozilla-openh264 vim gstreamer1-plugins-ugly gnome-tweaks tilix raw-thumbnailer fontconfig-enhanced-defaults
                            gstreamer1-plugin-openh264 libva-utils gstreamer1-vaapi

It seems to have fixed itself. I suspect that there was some issue on registry.fedoraproject.org on some mirrors.