Flatpak : outdated freedesktop Platform version preventing flathub installs

HI all, new to fedora here. Just installed V37 workstation. Copied my home folder over from an old debian stable system who died on me a few days ago (the PC it was installed on died, not the OS itself). I used cp -rp /oldhome /newhome after creating the new profile in fedora, then chown’ed everything to the new user:user.

I had no problems installing software from the software center, including fedora flatpaks, but with the exception of flathub installs, which all fail with the same error : not being able to checkout [checksum] into /home/user/.local/share/flatpak/runtime/org.freedesktop.Platform/x86_64/22.08/.[checksum]-[other checksum]: opening content object [yet another checksum]: fgetxattr(user.ostreemeta): no data available.

When looking into /home/user/.local/share/flatpak/runtime/org.freedesktop.Platform/x86_64/, I only find a 1.6 folder, but no 22.08 folder.

I tried sudo flatpak update, sudo flatpak uninstall --unused and sudo flatpak repair, but it did not change anything. flatpak list shows only Freedesktop.org Application Platform version 1.6 instead of 22.08.

Any help would be greatly appreciated since I cannot install anything from flathub right now :slightly_smiling_face:

1 Like

I would guess that since you copied everything from the debian home directory that you also have files under .local/ and .config/ (as well as other dot files in your home directory) that contain settings for debian and likely are not compatible with fedora.

I cannot tell you what is or is not compatible but there are times with just upgrading fedora from one version to another that things break because of changes in the installed apps but the system has retained the old config files.

I suggest you look there first. I have a few flatpaks installed, but do not have the ~/.local/share/flatpak/runtime/ directory tree.

1 Like

Hi Jeff V,

thanks for your reply, I’ll take another (deeper) look.


Deeper look taken, solution found:
sudo flatpak install org.freedesktop.Platform

After that you get a text menu where you can choose a version to install. It solved the installation problems I had.

1 Like