Firefox - no video playback in silverblue 33 - upgrade problems thereafter - rpm-ostree reset to the rescue

To cut it short, the following did it cleanly, after I used rpm-ostree reset to clean up a lot of layered package stuff that prevented me from doing an rpm-ostree update:

rpm-ostree install https://mirrors.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm 
https://mirrors.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

rpm-ostree install gstreamer1-libav

See also:
https://docs.fedoraproject.org/en-US/quick-docs/assembly_installing-plugins-for-playing-movies-and-music/

for only firefox without rpmfusion :

rpm-ostree install gstreamer1-plugin-openh264 mozilla-openh264

for firefox & epiphany with rpmfusion :

rpm-ostree install ffmpeg ffmpegthumbnailer

will give you thumbnails for mp4 & mkv videos as well.

1 Like

As an early adopter of Silverblue I’m still recommending to install the Firefox flatpak from Flathub and using that for your every day browsing. It comes with proper codec support by default and runs in a sandbox unlike the stock RPM version.

1 Like

with all due respect if you could be kind enough to define proper codec support

i have tried & tested flatpaks of epiphany / web, falkon, firefox, midori & faced problems with streaming videos from instagram, news channels & twitter videos.
on instagram i got either nothing or only sound.
on twitter i got a reload button which only plays 1-2 seconds of the video & the reload button comes back.
on news channels mostly i got various errors messages & if sometimes the video would played it would stall kinda like slow motion & the sound was totally out of sync.

am 100% sure about what i state.

Everything works. It is uploaded to Flathub by Mozilla and you don’t have to install any packages. Forget about the default Firefox that comes pre-installed.

Well basically this:

Ever since I started using the Firefox version from Flathub I’ve not had any issues playing audio or video. Note that this is a different, more complete, flatpak than the one distributed by Fedora in their own flatpak registry. That one too is lacking a lot of codecs.

if everything for you is youtube but obviously you have not had any issues.

YouTube, Netflix, Amazon PrimeVideo and I do not have any layered packages.
In Firefox from Flathub, mozilla-openh264 comes as a Firefox plugin and it is already activated so it doesn’t need to be installed from rpmfusion.
In Settings you need to enable DRM to get the Widevine plugin and that’s it.
I suggest you remove ffmpeg and the other packages from rpmfusion and try with a clean system.

And make sure that the flatpak you install is from Flathub not from Fedora.

will the mozilla-openh264 firefox plugin also give me thumbnails for mp4 & mkv videos?

i do.
please point me in the direction of a flatpak for samba.
a shining example of the incompetence of flatpaks is the clamtk flatpak.
will inform davem about it at the earliest.

flatpaks is definitely not the way forward, not yet.
thanks but no thanks.

i prefer not to have 2 firefox browsers on my system, it seems like an overkill.

i would rather make the default firefox browser perform.

i do not want to do the firefox override thingy & mess up the amazing silverblue.

Sorry but your reply isn’t fair. This thread is just about Firefox. You can run the RPM version with lots of layered packages or the Flathub one with all codecs embedded. So why are you trying to hijack this thread and trolling by starting about Nautilus and Samba?

And if you don’t think Flatpaks are the way forward then you’re free to stick with the regular Fedora edition. Nobody is forcing you to use Flatpak or Fedora Silverblue :wink: