Firefox 123 starts as X, not Wayland

Just updated to Firefox 123, and I noticed that my text was fuzzy. This is because Firefox had started in X, not Wayland. I’m on Sway WM, and this happens for all X windows as I have scaling enabled. So I confirmed with Xeyes.
I downgraded back to Firefox 119 and back on Wayland now.

1 Like

It’s possible that Firefox 123 introduced some compatibility issues with X or Sway WM’s scaling settings. You may want to monitor for future updates to see if the problem is addressed or consider reporting the issue to the Firefox or Sway WM development teams for further investigation.

Hello @theprogram ,
FF does not have anything to do with the display server, that is defaulted to Wayland, but can be chosen by the user at login. Any choice at login remains persistent over reboots until a new choice is made.

I’m pretty sure there’s a way to do this per user, but you can make all Mozilla products use Wayland by adding MOZ_ENABLE_WAYLAND=1 to your /etc/environment file.