Firefox does not honor display scale on Wayland

I am running Fedora KDE plasma on a 4k disply.
In System Settings/Display I have set Scale to 125%.
Everything I have tried except Firefox is honoring the scalling.

But Firefox is clear ignoring the scaling.
I’m using it with a font size of 30pt to be able to read pages.

Anyone else seeing this?

What do I need to do to fix/work around this?

$ rpm -q firefox
firefox-123.0-2.fc39.x86_64

$ uname -r
6.7.6-200.fc39.x86_64

$ inxi -Gxx
Graphics:
  Device-1: AMD Navi 32 [Radeon RX 7700 XT / 7800 XT] vendor: Gigabyte
    driver: amdgpu v: kernel arch: RDNA-3 pcie: speed: 16 GT/s lanes: 16 ports:
    active: DP-2 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 08:00.0
    chip-ID: 1002:747e
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,nouveau,vesa alternate: nv gpu: amdgpu
    display-ID: 0
  Monitor-1: DP-2 res: 3072x1728 size: N/A
  API: EGL v: 1.5 platforms: device: 0 drv: radeonsi device: 1 drv: swrast
    gbm: drv: kms_swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.6 glx-v: 1.4
    direct-render: yes renderer: AMD Radeon RX 7800 XT (radeonsi navi32 LLVM
    17.0.6 DRM 3.57 6.7.6-200.fc39.x86_64) device-ID: 1002:747e
    display-ID: :0.0
  API: Vulkan v: 1.3.268 surfaces: xcb,xlib,wayland device: 0
    type: discrete-gpu driver: mesa radv device-ID: 1002:747e device: 1
    type: cpu driver: mesa llvmpipe device-ID: 10005:0000

If you go to about:support on firefox does it indicate wayland for Window Protocol?

In the Graphics/Features section it says:

Window Protocol	wayland
Desktop Environment	kde

I see these env vars are set but do not know where they are defined.

$ env | grep QT_
QT_WAYLAND_DECORATION=adwaita
PLASMA_USE_QT_SCALING=1
QT_WAYLAND_FORCE_DPI=96
QT_AUTO_SCREEN_SCALE_FACTOR=0

Another data point.

I have just installed a fresh fedora on an external SSD and firefox is scaled on that install booted on the same hardware.

I’ll try creating a new user account and see if that has working firefox.

A fresh user does not have the problem.

I wonder where the setting that change the scaling is saved?

… It looks like those QT env variables are set on a fresh install.

Not having a lot of luck trying to break this … :frowning:

Tomorrow I’ll try moving the firefox profile from the broken user to the new user and see if the bug moves with the profile.

I guess I can also move the existing profile to one side and see if a new profile in by broken user account is then working.

I have created a new profile using about:profiles and the new profile does not have the issue. I tried to diff the prefs.js between the new and old profiles, but could not see anything obvious that would cause the problem.

If anyone else sees this the work around is to create a new profile.