Fedora - Are there any drivers for USB dongle TP-LINK WN823N RTL8192EU V3?

This USB wireless is available commonly for Ubuntu. On the CD and here are the files for Ubuntu:

But it appears that people have been using it on Fedora:
But I couldn’t find this in the former site:

There’s been a chipset driver for it (GitHub - Mange/rtl8192eu-linux-driver: Drivers for the rtl8192eu chipset for wireless adapters (D-Link DWA-131 rev E1 included!)). Is this out-dated because when I follow the instruction I get the return - apt-get: command not found…

Fedora use dnf command and instruction is for debian base distros.Anyway you can use this instructions if you already have network connection establish.

I have it and is recognize out of box :grinning:

This one after Mange’s will blacklist the built-in:
rpmbuild --rebuild https://github.com/rpmsphere/todo/raw/master/src-kmod/8192eu-4.4.1-1.src.rpm
rpm -Uvh $HOME/rpmbuild/RPMS/$HOSTTYPE/8192eu-kmod-4.4.1-1.$HOSTTYPE.rpm

Thanks bluebat. I haven’t attained an internet connection of any kind yet; it appears that my Ethernet is faulty and my Broadcom pci might be too, so now I’m trying for the USB. I’ve downloaded the source rpm and transferred it to my Fedora-installed laptop, but the --rebuild option reports unknown option, and sure enough it’s not listed under Usages

So it should have been detected automatically by Fedora 30?

Yes,it is automatically detect but driver is not good. We need to manually install driver and that involve kernel-devel package what is not installed by default … and you need internet …

Ok, another fresh installation. I have wired internet connection.
I’ve updated the Fedora 30 system - dnf install updates
I’ve installed rpmbuild - dnf install rpm-build
I’ve installed kernel-devel - dnf install kernel-devel
And here is my attempt to build the source file:

[root@localhost-live ~]# rpmbuild --rebuild https://github.com/rpmsphere/todo/raw/master/src-kmod/8192eu-4.4.1-1.src.rpm
Installing https://github.com/rpmsphere/todo/raw/master/src-kmod/8192eu-4.4.1-1.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.mZfbOZ
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd /root/rpmbuild/BUILD
+ rm -rf rtl8192eu-linux-driver-realtek-4.4.x
+ /usr/bin/unzip -qq /root/rpmbuild/SOURCES/rtl8192eu-linux-driver-realtek-4.4.x.zip
+ '[' 0 -ne 0 ']'
+ cd rtl8192eu-linux-driver-realtek-4.4.x
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ sed -i 's|VERIFY_READ, priv_cmd.buf, priv_cmd.total_len|priv_cmd.buf, priv_cmd.total_len|' os_dep/linux/rtw_android.c
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.FIyBzh
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd rtl8192eu-linux-driver-realtek-4.4.x
+ make
/var/tmp/rpm-tmp.FIyBzh: line 31: make: command not found
error: Bad exit status from /var/tmp/rpm-tmp.FIyBzh (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.FIyBzh (%build)
[root@localhost-live ~]#

I researched the make command and found that I needed rmpdevtools, so I installed (dnf install rpmdevtools) but got the same output. Well, except for the name of the tpm file:

+ make
/var/tmp/rpm-tmp.f7Va51: line 31: make: command not found
error: Bad exit status from /var/tmp/rpm-tmp.f7Va51 (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.f7Va51 (%build)
[root@localhost-live ~]#

I had the wrong devtools, though I suppose it can’t hurt to have the rpmdevtools on the system. I’ve now installed Development Tools (dnf groupinstall ‘Development Tools’)

Ok, next issue :slight_smile:

+ make
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.0.9-301.fc30.x86_64/build M=/root/rpmbuild/BUILD/rtl8192eu-linux-driver-realtek-4.4.x  modules
make[1]: *** /lib/modules/5.0.9-301.fc30.x86_64/build: No such file or directory.  Stop.
make: *** [Makefile:1700: modules] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.NxJynv (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.NxJynv (%build)
[root@localhost-live /]# ls
bin   dev  home  lib64       media  opt   root  sbin  sys  usr
boot  etc  lib   lost+found  mnt    proc  run   srv   tmp  var

I’ve checked and the directory and file (namely, build) are there.

Super you are on net !

Just in terminal

1 Like

Need kernel-devel package

I’m online, thanks, and thanks for the link.

However I’m getting the same error report:
[root@localhost-live RTL8192EU]# make
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.0.9-301.fc30.x86_64/build M=/RTL8192EU modules
make[1]: *** /lib/modules/5.0.9-301.fc30.x86_64/build: No such file or directory. Stop.
make: *** [Makefile:1828: modules] Error 2

kernel-devel is installed:
[root@localhost-live RTL8192EU]# dnf install kernel-devel
Last metadata expiration check: 2:34:36 ago on Sun 02 Jun 2019 03:41:09 AM EDT.
Package kernel-devel-5.1.5-300.fc30.x86_64 is already installed.
Dependencies resolved.
Nothing to do.

Did you update system?“Package kernel-devel-5.1.5-300.fc30.x86_64 is already installed” is package for new kernel.You must reboot and match kernel with kernel-development package

1 Like

It’s my error - again. Sorry; I entered dnf install update instead of dnf install upgrade and I haven’t been scrutinous with the output. The system is now upgrading. I’ll keep you posted.

Oh, that’s not right neither, for now I’m downloading Fedora 30 entirely, right?

No but downloads and update system look like it is 800+ mb

1 Like

Ok, progress. I upgraded (dnf upgrade) and rebooted, but got the same error message above. On repeat of the list above I rebooted before the make command. This time I got past that particular error. Does this mean that I successfully matched the newly installed kernel-devel with the kernel-development package?

Now my latest error report is this;

[root@localhost RTL8192EU]# make install
install -p -m 644 8192eu.ko /lib/modules/5.1.5-300.fc30.x86_64/kernel/drivers/net/wireless/
/sbin/depmod -a 5.1.5-300.fc30.x86_64
depmod: ERROR: failed to load symbols from /lib/modules/5.1.5-300.fc30.x86_64/kernel/drivers/target/iscsi/iscsi_target_mod.ko.xz: Input/output error
[root@localhost RTL8192EU]#

Sorry, i don’t know about this error nothing .Maybe someone will know about this more. Check you have kernel-modules-extra & kernel-modules packages installed. Just run dnf install kernel-modules-extra kernel-modules