How to update drivers of a USB WiFi dongle

i have the tp-link WN823N wifi adapter . but when i plug into the computer , it shows the wifi icon and all that but when i try to conncet with the wifi , it fails.
in ubuntu i had the same problem , but after i plug out and then plug in it connects.
it shows authentication error or something like that in fedora.

1)how to fix it
2)if it connects to the wifi then how to update the drivers of it?(please give me the line by line command)

what is the chipset powering this wifi adapter? find out using lsusb.

the chipset is RTL8192EU

1 Like

thanks for the info
but i don’t know much about linux
it would be very helpful if you give me all the commands
in ubuntu i tried this and it worked

sudo apt update
sudo apt-get install mokutil && mokutil --sb-state
sudo apt-get install git linux-headers-generic build-essential dkms
git clone GitHub - clnhub/rtl8192eu-linux: Realtek rtl8192eu official Linux driver, versions: (master),, 5.6.4 and (default)
cd rtl8192eu-linux/
sudo dkms add .
sudo dkms install rtl8192eu/1.0
echo “blacklist rtl8xxxu” | sudo tee /etc/modprobe.d/rtl8xxxu.conf

now what should i use in fedora?

Make sure to fully upgrade the system and boot the latest kernel:

sudo dnf upgrade --refresh

Then build the modules with DKMS:

sudo dnf install git dkms kernel-devel openssl
sudo git clone \
sudo sed -i -e "/^DEST_MODULE_LOCATION/s|/kernel/.*/|/extra|" \
sudo dkms add rtl8192eu/git
sudo systemctl restart dkms.service
sudo tee /etc/modprobe.d/rtl8192eu.conf << EOF > /dev/null
blacklist rtl8xxxu
sudo tee /etc/modules-load.d/rtl8192eu.conf << EOF > /dev/null
sudo systemctl restart systemd-modules-load.service

Form enrolling request if you need Secure Boot:

sudo mokutil -i /var/lib/dkms/ << EOI

Or disable Secure Boot in the BIOS/EFI settings.

1 Like