Fedora accounts ... libavatar

Really low priority problem :sunglasses: and I’m not sure where to ask this question, so I’ll try here!
The profile I have for my Fedora account (https://accounts.fedoraproject.org/) allows me to add an avatar. This is done on Fedora through libavatar. My picture is successfully uploaded on libavatar but never shows up on my Fedora account.
I just see

Is there something special about the format of the picture that is causing this? (I tried several formats with the same result).

1 Like

Did you upload your picture for your e-mail address or for OpenID? You can add your OpenID to Libravatar in the form of https://username.id.fedoraproject.org, for example mine is https://ersen.id.fedoraproject.org.

Yes, it’s identified by the openid. When I click on the change avatar button on the fedora profile page, I get sent to libavatar which then sends me back to Fedora for authentication.

Some Fedora services uses e-mail for avatars and some uses OpenID. Looks like Fedora Accounts page uses e-mail address for getting avatars from the Libravatar.

Well neither seen to work for me. The email addresses are the same on both systems.

I am a bit late for this, and I apologize if I am “necroposting”, but when you create a libravatar it uses the openID of Fedora Project as default. So why I did is add my email on libravatar as well. So now on AskFedora and Fedora Discussion on settings/preferences when choosing the picture profile I can select Libravatar (which now has my email as reference), click on the “refresh” icon next to it, then it will show the profile picture. But in Fedora accounts, it does not really show, it is a bit odd.

I am a bit late also, but when I added my avatar to ask.fp I simply opened my profile, selected preferences, then added the image I wanted to the Profile Picture. There is an ‘edit’ icon there to allow selecting or uploading the image.

Yes, associating the email address to the libavatar profile did it.
I guess, Fedora presents libavatar with the email address as ID rather than the Fedora login name.
I don’t think I got a heads up to use the email address on libavatar.