Fedora 40 KDE: not possible to add keyboard shortcuts

Hi, in the Fedora 40 KDE spin as well as in Kinoite is it impossible to add keyboard shorts in the shape of a Command or script.
When I do that I get an error message saying:

Error while communicating with the global shortcuts service

I looked up the global shortcuts service and it is there, it is loaded but inactive from the moment of boot.
I can restart it and for a brief moment (30-40ms) it is active and then it is inactive again.

Does anybody else experience the same issue?
I want to add 5 shortcuts which would make life so much easier, but till now it is impossible to

1 Like

Added kde-plasma

So on Fedora 40 Kinoite it works fine. I tried to add one with content

notify-send "test"

and assigned a combination, it worked.

Worked fine for me a little over 2 weeks ago on F40 KDE (not Kinoite)

1 Like

Well, it is great to see for you guys it does work, here it doesn’t. I just tried it again and immediately I get the same error message.
I just did another attempt, now with: kate ~/testfile and it did work.
Now I wonder what I have to write to get libreoffice calc work.

If you create a new user, can you reproduce this issue with that account? You can delete it after you are done.

Great help. :+1:
I added a new user and when logged in as that new user it does work.
Now is the question why doesn’t it work when I am logged in as me. What to do about that?

If the issue can only be reproduced in your account, and not in the new account, it’s more likely related to your settings.

You might try moving ~/.config/kglobalshortcutsrc to another location to see if the default shortcut settings work. If not, you can move it back.

1 Like

Why didn’t I think about that? I did what you you wrote but unfortunately it didn’t help.
So now what I want to do is: a complete re-install. I have everything in a back-up so it is just a matter of some hours and I have a working Kinoite again. I’ll try to add the shortcuts immediately after the first boot, just to see if it works then.

Thank you very much for your help. I’ll let you know what the outcome of the re-install does.

So, I did a complete re-install of Kinoite, copied all my data files from the NAS, configured the system, Dolphin and Konsole to my liking.

And most importantly: i added shortcuts. Yes, it works, and if I want to it also doesn’t work. At least I think I have found the reason. During copying my data files I started KDE System-settings and did what I always do.
One of those things is the setup for the keyboard:
switch on Num-lock, add a different layout: in my case Eurkey. This is a layout with lots of extra characters, like ä, Ä, ë,ü, ö, ß and many more. I use this for many years already.
I then started to add the shortcuts and you guessed it: it didn’t work. Why not? I started thinking what did I do from the first boot till now? And then I knew it: added the Eurkey keyboard layout.

I deleted it, rebooted and added 5 shortcuts, one by one without any problem. I now have it switched on again, because I like it and without having to add shortcuts it works great.

Don’t you hate it when that happens: also now with the layout added it works. So, now I have no idea why I couldn’t add shortcuts and why I can now.
Any idea?

I’m glad it’s working for you now. If you can reliably reproduce the bug and it seems to be related to KDE, you might consider reporting it to the KDE community at discuss.kde.org or creating a bug report at bugs.kde.org.

I did already, I will cancel the bugreport since it is working now.
Thank you for your help and ideas.

And this is what atomic distros need to fix.

You dont need a reinstall, just add a new user and add it to wheel flatpak libvirt groups.

Delete the old user account and that is it.

But the way better option would be a global reset feature for KDE Plasma.

They allow to revert every settings page back to normal, but not all at once.

So this is actually something Plasma should fix.

You probably could just as the layout was different you made different shortcuts ? Now with the correct layout the keys are there where you expect them … and they do what you expect todo.

1 Like