[SOLVED][F40 KDE Plasma spin] Keyboard doesn’t work in SDDM

Solution: default conf file (/etc/sddm.conf) has qtvirtualkeyboard input method but /usr/lib/sddm/sddm.conf.d/plasma-wayland.conf has maliit-keyboard input method.

$ sudo nano /usr/lib/sddm/sddm.conf.d/plasma-wayland.conf
--inputmethod qtvirtualkeyboard

Maybe you should try to change default config file, but I had issues after login so I only changed wayland configuration. Don’t know if it’s a right way to fix this issue but keyboard and SDDM works flawlessly now. Any other suggestions to fix this problem are welcomr

Hello. I enjoyed F40 update a lot! It’s very polished and great update but I have one problem with it. My keyboard after few reboots doesn’t work in SDDM login screen and I have to use another keyboard to log in and turn on auto login to use system without second keyboard. Switching to X11 session, reinstalling kernel, sddm and libinput didn’t help me. Any suggestions what did go wrong? I don’t want to use auto login due to privacy reasons and I need a workable SDDM anyway (for example to restart session to apply some changes).

Thanks in advance!