Fedora 39: External monitor starts blink black after recent updates

I have Lenovo IdeaPad 5 14ARE05 notebook with external ASUS ProArt PA279CV 27" monitor connected via DisplayPort cable. The system worked flawlessly until system updates installed during reboot yesterday. After that external monitor started randomly blink black for a second, without any pattern—it can blink one time at three minutes or three times in a minute.

I can’t see any related logs during that flickers in my journalctl. I run sudo journalctl -f in terminal and when display blinks it outputs nothing.

It is 100% not a hardware reason — the only change happened is system updates installed.

What else I can check to diagnose the problem?

System Details Report

Report details

  • Date generated: 2023-11-22 08:23:16

Hardware Information:

  • Hardware Model: Lenovo IdeaPad 5 14ARE05
  • Memory: 16.0 GiB
  • Processor: AMD Ryzen™ 5 4600U with Radeon™ Graphics × 12
  • Graphics: AMD Radeon™ Graphics
  • Disk Capacity: 512.1 GB

Software Information:

  • Firmware Version: DTCN27WW(V1.13)
  • OS Name: Fedora Linux 39 (Workstation Edition)
  • OS Build: (null)
  • OS Type: 64-bit
  • GNOME Version: 45.1
  • Windowing System: Wayland
  • Kernel Version: Linux 6.5.12-300.fc39.x86_64

Try booting on the previous linux kernel and see if the problem goes away.
If so it may be a kernel bug that needs reporting.

Please also post the output of inxi -Fzxx you may need to install inxi package.

It could be another instance of this bug:

I will try to do it when I get to know how

The output of inxi command

Kernel: 6.5.12-300.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
v: 2.40-13.fc39 Desktop: GNOME v: 45.1 tk: GTK v: 3.24.38 wm: gnome-shell
dm: GDM Distro: Fedora release 39 (Thirty Nine)
Type: Laptop System: LENOVO product: 81YM v: IdeaPad 5 14ARE05
serial: Chassis: type: 10 v: IdeaPad 5 14ARE05
Mobo: LENOVO model: LNVNB161216 v: No DPK serial:
UEFI: LENOVO v: DTCN27WW(V1.13) date: 05/30/2022
ID-1: BAT1 charge: 32.0 Wh (59.5%) condition: 53.8/56.5 Wh (95.2%)
volts: 11.9 min: 11.6 model: 0x43 0x65 0x6C 0x78 0x70 0x72 0x74 0x00 0x32
0x30 0x31 0x4C 0x31 0x39 0x43 0x33 0x50 0x46 serial:
status: not charging
Info: 6-core model: AMD Ryzen 5 4600U with Radeon Graphics bits: 64
type: MT MCP arch: Zen 2 rev: 1 cache: L1: 384 KiB L2: 3 MiB L3: 8 MiB
Speed (MHz): avg: 1399 high: 1400 min/max: 1400/2100 boost: enabled cores:
1: 1400 2: 1400 3: 1400 4: 1397 5: 1400 6: 1400 7: 1397 8: 1400 9: 1397
10: 1400 11: 1400 12: 1400 bogomips: 50304
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5
pcie: speed: 8 GT/s lanes: 16 ports: active: DP-1,eDP-1 empty: HDMI-A-1
bus-ID: 04:00.0 chip-ID: 1002:1636 temp: 41.0 C
Device-2: Chicony driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
lanes: 1 bus-ID: 1-3:3 chip-ID: 04f2:b6c2
Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 23.2.2
compositor: gnome-shell driver: gpu: amdgpu display-ID: 0
Monitor-1: DP-1 model: ASUS PA279 res: 3840x2160 dpi: 163
diag: 685mm (27")
Monitor-2: eDP-1 model: BOE Display 0x08d7 res: 1920x1080 dpi: 158
diag: 355mm (14")
API: OpenGL v: 4.6 vendor: amd mesa v: 23.2.1 glx-v: 1.4 es-v: 3.2
direct-render: yes renderer: AMD Radeon Graphics (renoir LLVM 16.0.6 DRM
3.54 6.5.12-300.fc39.x86_64) device-ID: 1002:1636 display-ID: :0.0
API: EGL Message: EGL data requires eglinfo. Check --recommends.
Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
bus-ID: 04:00.1 chip-ID: 1002:1637
Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
driver: snd_rn_pci_acp3x v: kernel pcie: speed: 8 GT/s lanes: 16
bus-ID: 04:00.5 chip-ID: 1022:15e2
Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 04:00.6 chip-ID: 1022:15e3
API: ALSA v: k6.5.12-300.fc39.x86_64 status: kernel-api
Server-1: JACK v: 1.9.22 status: off
Server-2: PipeWire v: 0.3.85 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
vendor: Lenovo driver: ath10k_pci v: kernel pcie: speed: 2.5 GT/s lanes: 1
bus-ID: 03:00.0 chip-ID: 168c:003e temp: 45.0 C
IF: wlo1 state: up mac:
Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 driver: btusb v: 0.8
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 3-4:3 chip-ID: 0cf3:e300
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: bt-v: 4.2 lmp-v: 8
Local Storage: total: 476.94 GiB used: 32.4 GiB (6.8%)
ID-1: /dev/nvme0n1 vendor: Samsung model: MZALQ512HALU-000L2
size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: temp: 30.9 C
ID-1: / size: 475.35 GiB used: 32.04 GiB (6.7%) fs: btrfs
dev: /dev/nvme0n1p3
ID-2: /boot size: 973.4 MiB used: 350.7 MiB (36.0%) fs: ext4
dev: /dev/nvme0n1p2
ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
dev: /dev/nvme0n1p1
ID-4: /home size: 475.35 GiB used: 32.04 GiB (6.7%) fs: btrfs
dev: /dev/nvme0n1p3
ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 49.4 C mobo: N/A gpu: amdgpu temp: 42.0 C
Fan Speeds (rpm): N/A
Processes: 377 Uptime: 4h 26m Memory: total: 16 GiB note: est.
available: 14.98 GiB used: 5.09 GiB (34.0%) Init: systemd v: 254
target: graphical (5) default: graphical Compilers: gcc: 13.2.1
clang: 17.0.4 Packages: pm: rpm pkgs: N/A note: see --rpm pm: flatpak
pkgs: 26 Shell: Bash v: 5.2.21 running-in: gnome-terminal inxi: 3.3.31

The reported problem has weird behavior—after 4.5 hours of uptime display has stoped to blink and last hour I clearly had no problem. Really strange.

Edited: It still blanks — at five hour of uptime it happened again.

When you boot do you see the grub menu?

As soon as it appear press SPACE to stop the timer.
Use the arrow keys to select the kernel you want to boot.
Press RETURN to boot that kernel.

If the grub menu does not show during boot it may be forced to appear by holding down the shift key as soon as power is applied during boot. Then you can select any of the currently installed kernels for booting.

I don’t have a grub menu appearing on screen by default. Holding Shift key during boot didn’t help, but pressing F8 did the trick:

But the screen keeps blinking no matter what kernel I choose to boot. This forced me to check the hardware anyway.

It’s my mistake. Sorry for that. I clean out by blowing the cable and type-c slot and the problem was gone. Events of system update and connecting/disconnecting of the display port cable took a place in the same time so I thought about the software first.

Sorry for the false alarm and thanks for helping.